Bug 203872 - Hideous OOo character commit bug
Hideous OOo character commit bug
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
: 205560 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-24 01:32 EDT by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.4-3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 06:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 69051 None None None Never

  None (edit)
Description Jong Bae KO 2006-08-24 01:32:19 EDT
Description of problem:
When I type Hangul in both applications, It doesn't produce character with arrow
button.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. activate SCIM
2. type "gksrmf(한글)" in oowriter . A cursor should be on "글"".
3. press any arrow button.
  
Actual results:
한

Expected results:
한글

Additional info:
I think buffer problem.
Comment 1 Caolan McNamara 2006-08-24 04:12:55 EDT
Hmm, I think this is working for me now. Might be working because of the
fontconfig fixes.
Comment 2 Jong Bae KO 2006-08-24 23:21:39 EDT
Hmm. It still doesn't work in openoffice, but it is working in gedit.
is it fontconfig problem?
Comment 3 Caolan McNamara 2006-08-25 02:54:56 EDT
No I mean the use of fontconfig in OOo itself, not a fontconfig bug, but a
problem in how we do some font substitution work based on fontconfig feedback
Comment 4 Caolan McNamara 2006-08-29 05:56:42 EDT
Well, that is odd. It worked on my x86_64 box, but not on the i386 one, and the
code in question is a horrible tangled hack to try and munge a single character
im commit into a key event to keep older OOo widgets working. But it tries to
keep count of the real keystrokes pressed to re-use for a single character
commit, and this fails horribly when (as on my i386) the events are in sequence
of...

last pre-edit changed
right arrow pressed
OOo gets "right-arrow" key event
OOo gets "buffer commit" event, check to see what key was pressed and reuse
keycode (which is arrow)
   document gets -> arrow keycode, but with "unicode character from buffer"
value, processed as arrow
arrow key processed
   document gets -> arrow keycode, and with arrow value, processed as arrow

on my x86_64 the sequence happens to be...

last pre-edit changed
right arrow pressed
OOo gets "buffer commit" event, check to see what key was pressed and reuse
keycode (which is either nothing, or e.g. 'k')
   document gets -> 'k' keycode, but with "unicode character from buffer" value,
processed as "normal character with val unicode character"
OOo gets "right-arrow" key event
arrow key processed
   document gets -> arrow keycode, and with arrow value, processed as arrow
Comment 5 Caolan McNamara 2006-08-29 07:16:19 EDT
I have an alternative patch which solves this for me, but let's check with
upstream for any obvious flaws
Comment 6 Caolan McNamara 2006-08-29 07:37:20 EDT
I'll check my changes in provisionally.
Comment 7 Jong Bae KO 2006-08-31 02:23:13 EDT
I tested on openoffice.org-writer-2.0.4-2.2 which is released on Tue 29 Aug 2006
10:03:13
It isn't upstreamed yet.
I will test it on newer version later.
Comment 8 Satyabrata Maitra 2006-09-05 09:33:31 EDT
Hi Jong

I am not the native speaker of any of the CJK language. So, I want some more
info to test this bug. Would u please supply these informations!!

1. did u mean scim-hangul in ko_KR to be selected from scim table?
2. typing "gksrmf"  for me its showing korean chars. And what is meant by 
   "(한글)"? did not understand really!! pls explain once again. 
3. Which arrow key it is to be pressed. up, down, left, or right arrow key? pls 
   inform.
4. what is meant by the sentence -- "A cursor should be on "글"" " ? did not 
   get it really!! Please explain.

Cheers
Satya
Comment 9 Caolan McNamara 2006-09-05 09:53:47 EDT
woah, I have a fix for this checked in. But not delivered in a build yet. 

1. yes
2. yes, gksrmf with that input engine active will show two korean characters,
and the 2nd one will be highlighted at this stage
3. any of them, e.g. right arrow
4. the problem is that the highlighted second character will disappear when e.g.
right arrow is pressed

What we'd like to happen is that the highlighted character gets committed to the
document instead of disappearing.
Comment 10 Jong Bae KO 2006-09-06 21:02:12 EDT
When is it going to build?
Comment 11 Caolan McNamara 2006-09-08 06:09:16 EDT
*** Bug 205560 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.