Bug 20400 - ps figures buggy under xdvi
ps figures buggy under xdvi
Status: CLOSED DUPLICATE of bug 19212
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2000-11-05 18:34 EST by oreilly
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-01-19 09:44:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description oreilly 2000-11-05 18:34:46 EST
under ghostscript 5.50-1 and tetex-xdvi 1.0.6-11, xdvi does not display
embedded postscript figures in latex documents correctly.  specifically,
bits of text in figures will not display sometimes, and then will show up
randomly on other pages.

figures are included using the following latex code:

\usepackage [dvips]{graphicx}

this problem does not show up with earlier versions of ghostscript (e.g,

also, i can't seem to get the buttons to appear on the right hand side of
the window, despite toggling using the x button.
Comment 1 oreilly 2000-11-06 00:02:08 EST
This bug should probably also be listed under tetex (package tetex-xdvi) -- it
is really in the interaction between xdvi and gs.
Comment 2 Jeff Johnson 2000-12-27 21:13:18 EST
Can you supply a complete example that exhibits the problem?
Comment 3 oreilly 2001-01-11 19:10:19 EST
Here is a complete example that exhibits the problem.   The first file is the
.tex file, and the second is the .ps file for the included figure.

Begin gsbug.tex:
\documentclass {article}

This is a minimal test document for reproducing a bug in the
interaction between gs (ghostscript) and xdvi in displaying postscript
figures with text labels.  This bug only appears with gs 5.50, not in
5.10.  The bug is that text in the figure will not be displayed
sometimes, and will appear incorrectly on other pages at other times.
To see the bug, latex this file, then xdvi the .dvi file (I used
version 22.05d-k that comes with redhat 6.2), and then flip back and
forth between the pages.  I find that the 2nd line of text does not
appear on the first page, and then shows up on the second page.




This is the second page.

Begin gsbug.fig.ps:
%!PS-Adobe-2.0 EPSF-1.2
%%Creator: Randall O'Reilly
%%DocumentFonts: Helvetica
%%Pages: 1
%%BoundingBox: 50 70 260 155

%%Page: 1 1

0 0 0 setcolor
1 setlinewidth

57 76 moveto
57 147 lineto
255 147 lineto
255 76 lineto

/Helvetica findfont
12 scalefont setfont
60 120 moveto
(this is some text to test) show

60 80 moveto
(and some more) show


Comment 4 Tim Waugh 2001-02-02 11:38:19 EST
This appears to be the same as bug 19212, which is fixed.

*** This bug has been marked as a duplicate of 19212 ***

Note You need to log in before you can comment on or make changes to this bug.