Bug 204005 - Fatal exception during kickstart install
Summary: Fatal exception during kickstart install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 204014 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-24 22:15 UTC by Andrew Kroeger
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 22:31:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log from failed install (30.57 KB, text/plain)
2006-08-24 22:15 UTC, Andrew Kroeger
no flags Details
kickstart file from failed install (3.00 KB, text/plain)
2006-08-24 22:16 UTC, Andrew Kroeger
no flags Details

Description Andrew Kroeger 2006-08-24 22:15:41 UTC
Created attachment 134865 [details]
anaconda.log from failed install

Comment 1 Andrew Kroeger 2006-08-24 22:15:41 UTC
Description of problem:
Encounter the following error when attempting a kickstart install (not sure if
it's kickstart-specific, but not having seen it reported yet leads me to believe
so):
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 944, in ?
    anaconda.intf.run(anaconda)
  File "/usr/lib/anaconda/text.py", line 491, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 222, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/backend.py", line 149, in doRepoSetup
    anaconda.backend.doRepoSetup(anaconda)
  File "/usr/lib/anaconda/yuminstall.py", line 651, in doRepoSetup
    self.ayum.doRpmDBSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 252, in doRpmDBSetup
    self.rpmdb.buildIndexes()
  File "/usr/lib/python2.4/site-packages/yum/rpmsack.py", line 65, in buildIndexes
    raise PackageSackError, "Match Iterators not supported in rpm. Please
upgrade rpm-python"
PackageSackError: Match Iterators not supported in rpm. Please upgrade rpm-python

Version-Release number of selected component (if applicable):
Most recent build (2006-08-24 ~04:20)

How reproducible:
Always

Steps to Reproduce:
1. Attempt kickstart install
  
Actual results:
Above error

Expected results:
Successful install

Additional info:
Attaching full anaconda.log & kickstart file used for install.

Comment 2 Andrew Kroeger 2006-08-24 22:16:50 UTC
Created attachment 134866 [details]
kickstart file from failed install

Comment 3 Jeremy Katz 2006-08-24 22:31:16 UTC
Fixed in yum-2.9.5-2

Comment 4 Jeremy Katz 2006-08-25 01:13:24 UTC
*** Bug 204014 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.