Bug 204027 - ** glibc detected *** /usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus: corrupted double-linked list: 0x0000000001e1a130 ***
** glibc detected *** /usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus: cor...
Status: CLOSED DUPLICATE of bug 203735
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 203765
  Show dependency treegraph
 
Reported: 2006-08-24 23:59 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-25 09:54:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Successful build log on FC5 x86_64 (800.21 KB, text/plain)
2006-08-25 10:28 EDT, Chris Schanzle
no flags Details

  None (edit)
Description Ralf Corsepius 2006-08-24 23:59:13 EDT
Description of problem:
Building OpenSceneGraph-1.1 for x86_64 in FE's buildsystem fails with

...
g++  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -W -Wall -fPIC -pipe
-I../../../../include -I/builddir/build/BUILD/OSG_OP_OT-1.1/OpenThreads/include
-I/builddir/build/BUILD/OSG_OP_OT-1.1/Producer/include  -c ../BoundingBox.cpp
*** glibc detected *** /usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus:
corrupted double-linked list: 0x0000000001e1a130 ***
======= Backtrace: =========
/lib64/libc.so.6[0x2aaaaad35ee7]
/lib64/libc.so.6[0x2aaaaad38302]
/lib64/libc.so.6(__libc_malloc+0x7d)[0x2aaaaad39b7d]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x86b248]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x7da2a9]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x778574]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x77877c]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x778799]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x4d1e31]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x477db6]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x7b2cca]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x7b30bf]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x443a1f]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x4b9e1f]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x75a775]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x2aaaaace6aa4]
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus[0x402399]
======= Memory map: ========
00400000-00a01000 r-xp 00000000 09:03 165055                            
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus
00c01000-00c08000 rw-p 00601000 09:03 165055                            
/usr/libexec/gcc/x86_64-redhat-linux/4.1.1/cc1plus
00c08000-08b98000 rw-p 00c08000 00:00 0                                  [heap]
2aaaaaaab000-2aaaaaac5000 r-xp 00000000 09:03 34243                     
/lib64/ld-2.4.90.so
2aaaaaac5000-2aaaaaac7000 rw-p 2aaaaaac5000 00:00 0 
2aaaaaac9000-2aaaaaaca000 rw-p 2aaaaaac9000 00:00 0 
2aaaaaaeb000-2aaaaabfb000 rw-p 2aaaaaaeb000 00:00 0 
2aaaaacc4000-2aaaaacc5000 r--p 00019000 09:03 34243                     
/lib64/ld-2.4.90.so
2aaaaacc5000-2aaaaacc6000 rw-p 0001a000 09:03 34243                     
/lib64/ld-2.4.90.so
2aaaaacc6000-2aaaaae0a000 r-xp 00000000 09:03 34251                     
/lib64/libc-2.4.90.so
2aaaaae0a000-2aaaab009000 ---p 00144000 09:03 34251                     
/lib64/libc-2.4.90.so
2aaaab009000-2aaaab00d000 r--p 00143000 09:03 34251                     
/lib64/libc-2.4.90.so
2aaaab00d000-2aaaab00e000 rw-p 00147000 09:03 34251                     
/lib64/libc-2.4.90.so
2aaaab00e000-2aaaab1ce000 rw-p 2aaaab00e000 00:00 0 
2aaaab1cf000-2aaaab20f000 rw-p 2aaaab1cf000 00:00 0 
[..]

To me, this looks like a bug in GCC (or glibc).


Version-Release number of selected component (if applicable):
gcc-4.1.1-18/gcc-c++-4.1.1-18 [rawhide]

How reproducible:
Unknown.

Steps to Reproduce:
1. Check out OpenSceneGraph/devel from FE's CVS
2. Build it
  
Actual results:
See above.

Expected results:
Function.

Additional info:
I don't have access to x86_64 platforms.
Locally building this rpm on FC5/i386 doesn't expose this error.
Comment 2 Leszek Matok 2006-08-25 07:34:50 EDT
Isn't it possible do add BuildRequires: gcc-debuginfo? :)
Comment 3 Ralf Corsepius 2006-08-25 08:03:24 EDT
(In reply to comment #2)
> Isn't it possible do add BuildRequires: gcc-debuginfo? :)

What would this be useful for?
Comment 4 Jakub Jelinek 2006-08-25 09:54:19 EDT

*** This bug has been marked as a duplicate of 203735 ***
Comment 5 Chris Schanzle 2006-08-25 10:28:08 EDT
Created attachment 134919 [details]
Successful build log on FC5 x86_64

No problems building on FC5 x86_64 (nice two-hour stress test for AMD64 3500+
2GB)
Comment 6 Chris Schanzle 2006-08-25 10:42:48 EDT
Sorry, meant to post that log to 203765.  Please delete if possible.

Note You need to log in before you can comment on or make changes to this bug.