Bug 204063 - Raritan KVM USB dongle needs to be added to the USB HID blacklist
Raritan KVM USB dongle needs to be added to the USB HID blacklist
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Feeney
Brian Brock
:
: 204064 (view as bug list)
Depends On:
Blocks: 190484 199571 232471 232477
  Show dependency treegraph
 
Reported: 2006-08-25 07:16 EDT by Raghavendra Biligiri
Modified: 2007-11-16 20:14 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 23:25:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes this Issue (1.18 KB, patch)
2006-08-25 07:20 EDT, Raghavendra Biligiri
no flags Details | Diff

  None (edit)
Description Raghavendra Biligiri 2006-08-25 07:16:03 EDT
Description of problem:
During Installation the host tries to enumerate the keyboard/mouse dongle for 
the Raritan KVM.At this time timeouts have been observed. So if the system has 
USB Floppy/CDROM and if the Raritan USB KVM Dongle is being enumerated first 
then due to these timeouts the usb-storage driver will not be loaded.So the USB 
storage devices will be inaccessible.
Adding the Raritan KVM USB dongle to the blacklist fixes this issue

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Raghavendra Biligiri 2006-08-25 07:20:48 EDT
Created attachment 134908 [details]
Patch that fixes this Issue
Comment 2 Raghavendra Biligiri 2006-08-25 07:22:15 EDT
Patch has been submitted upstream.
Comment 3 Raghavendra Biligiri 2006-10-12 06:20:30 EDT
Patch has been accepted upstream.
Request RedHat to include the patch in the next Update.
Comment 4 Linda Wang 2006-11-06 11:22:29 EST
*** Bug 204064 has been marked as a duplicate of this bug. ***
Comment 5 RHEL Product and Program Management 2006-11-29 15:08:46 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Samuel Benjamin 2006-11-29 18:19:31 EST
Requesting QA ACK. Patch that fixes problem is attached to case.
Comment 8 John Feeney 2006-12-14 13:24:49 EST
Dell tested successfully so posted patch to rhkernel list. Changing state to POST.
Comment 9 Jason Baron 2006-12-20 14:00:22 EST
committed in stream U5 build 42.33. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 10 Raghavendra Biligiri 2006-12-22 08:16:50 EST
Issue not reproducible with test kernel(kernel-2.6.9-42.35)
Comment 11 Jay Turner 2007-01-02 08:43:43 EST
QE ack for RHEL4.5.
Comment 12 Red Hat Bugzilla 2007-02-08 15:36:19 EST
Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2007:9073-03.
http://errata.devel.redhat.com/errata/showrequest.cgi?advisory=4730
Comment 14 Issue Tracker 2007-04-19 18:05:59 EDT
A fix for this issue has been included in RHEL4.5. Please test the Release
Candidate of RHEL4.5, which was released today to Partners, and let us know
if the problem is resolved. The Release Candidate can be downloaded from
here:

ftp://partners.redhat.com/af38ac4316ba20df2dec5f990913396d

gcase assigned to issue for Dell-Engineering.
Internal Status set to 'Waiting on Customer'
Status set to: Waiting on Client
Resolution set to: 'RHEL 4.5'

This event sent from IssueTracker by gcase 
 issue 100612
Comment 16 Red Hat Bugzilla 2007-05-07 23:25:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.