Bug 2041315 - Please branch and build python-matplotlib in epel9
Summary: Please branch and build python-matplotlib in epel9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-matplotlib
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carl George 🤠
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2081723 (view as bug list)
Depends On: 2030928 2071400 2074197 2081726 2093516 2158537
Blocks: EPELPackagersSIG 2032550 2041316 2081722 2127146 2127149 2159812
TreeView+ depends on / blocked
 
Reported: 2022-01-17 04:45 UTC by Davide Cavalca
Modified: 2023-05-18 04:37 UTC (History)
16 users (show)

Fixed In Version: python-matplotlib-3.4.3-3.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-18 04:37:13 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Davide Cavalca 2022-01-17 04:45:55 UTC
Please branch and build python-matplotlib in epel9.

If you do not wish to maintain python-matplotlib in epel9,
or do not think you will be able to do this in a timely manner,
the EPEL Packaging SIG would be happy to be a co-maintainer of the package.

Comment 1 Elliott Sales de Andrade 2022-01-17 06:00:23 UTC
I am not interested in doing that maintenance.

Comment 2 Davide Cavalca 2022-02-08 18:37:04 UTC
That's fine, in that case the EPEL Packagers SIG would be happy to be a co-maintainer of the package. Please add the epel-packagers-sig group through
https://src.fedoraproject.org/rpms/python-matplotlib/addgroup
and grant it commit access, or collaborator access on epel* branches.

Thanks!

Comment 3 Elliott Sales de Andrade 2022-05-05 02:18:02 UTC
*** Bug 2081723 has been marked as a duplicate of this bug. ***

Comment 4 Jonathan Wright 2022-08-25 15:21:14 UTC
Will you be able to branch and build python-matplotlib in epel9?
I would be happy to be a co-maintainer if you do not wish
to build it on epel9 (FAS: jonathanspw).

Comment 5 Jonathan Wright 2022-08-25 15:29:03 UTC
@dcavalca it looks like epel sig was added to this package.  Do you by chance have time to build it?

Comment 6 Davide Cavalca 2022-08-25 16:46:11 UTC
This package has a bunch of dependencies that need to be sorted out first (see the bugs linked as depends on here).

Comment 7 Orion Poplawski 2023-02-26 20:49:21 UTC
Checking in from my perspective:

* Carl George suggesting building python-matplotlib first with tests disabled to bootstrap without the pikepdf dependency.  This seems reasonable.
* Looks like matplotlib 3.5.0+ requires fonttools >= 4.22.0, but we're getting 4.19.1.  I've asked in the fonttools bug if this is the latest possible.
* If the above is the case it seems like with should go with 3.4.3 commit 8e6d614869bd34b0b7531e5890d71ffcc13328db - scratch build here: https://koji.fedoraproject.org/koji/taskinfo?taskID=98038905

Comment 8 Carl George 🤠 2023-04-08 03:29:44 UTC
Small update, the fonttools maintainer bumped the epel9 package up to 4.38.0 [0].  That will let us use a newer version than 3.4.3, however we're still limited to < 3.6 because that version bumped the setuptools_scm requirement to version 7 [1], and we only have version 6 in RHEL 9.  Version 3.5.3 (the f36 branch) seems like it will work.

[0] https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-6a2ccf5912
[1] https://github.com/matplotlib/matplotlib/commit/a31a01623283f3672b79dc2736957b4fd49ebe07

Comment 9 Carl George 🤠 2023-04-11 03:08:34 UTC
Scratch that, it seems there is test data that is specific to the version of freetype available.

https://src.fedoraproject.org/rpms/python-matplotlib/blob/f34/f/python-matplotlib.spec#_64

Based on that, we will need to use sources from the f34 branch, version 3.4.4, in order to match RHEL 9's freetype 2.10.4.

https://github.com/QuLogic/mpl-images/tree/v3.4.3-with-freetype-2.10.4

Comment 10 Carl George 🤠 2023-04-15 06:41:57 UTC
I was able to sort out successful builds of pikepdf and matplotlib in COPR.

https://copr.fedorainfracloud.org/coprs/carlwgeorge/matplotlib/

Here's the necessary PR for matplotlib, but it won't be able to be built in koji until pikepdf is available, which is blocked until RHEL 9.2 is released.

https://src.fedoraproject.org/rpms/python-matplotlib/pull-request/38

Comment 11 Fedora Update System 2023-05-09 22:35:16 UTC
FEDORA-EPEL-2023-76a7a89a90 has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-76a7a89a90

Comment 12 Fedora Update System 2023-05-10 03:04:10 UTC
FEDORA-EPEL-2023-76a7a89a90 has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-76a7a89a90

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2023-05-18 04:37:13 UTC
FEDORA-EPEL-2023-76a7a89a90 has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.