Bug 204170 - elfutils don't pass testsuite on alpha
elfutils don't pass testsuite on alpha
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
10
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
bzcl34nup
: Reopened
: 318371 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 06:58 EDT by Jakub Bogusz
Modified: 2009-07-23 15:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.128
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 15:38:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update alpha platform support (for elfutils 0.123) (6.44 KB, patch)
2006-08-26 06:59 EDT, Jakub Bogusz
no flags Details | Diff
Update alpha platform support (for elfutils 0.124) (6.22 KB, patch)
2006-11-17 11:57 EST, Jakub Bogusz
no flags Details | Diff
Update alpha platform support (for elfutils 0.126) (4.69 KB, patch)
2007-03-16 15:52 EDT, Jakub Bogusz
no flags Details | Diff
Partial `eu-readelf -a addr2line` output on alpha (15.29 KB, text/plain)
2007-09-15 16:11 EDT, Jakub Bogusz
no flags Details
`eu-readelf -Sl libelf.so` output on alpha (4.68 KB, application/octet-stream)
2007-09-15 16:12 EDT, Jakub Bogusz
no flags Details
`eu-readelf -Sl libelf.so` output on sparc (3.79 KB, application/octet-stream)
2007-09-15 16:13 EDT, Jakub Bogusz
no flags Details
`eu-readelf -Sl libelf.so` output on sparc64 (4.09 KB, application/octet-stream)
2007-09-15 16:14 EDT, Jakub Bogusz
no flags Details
eu-readelf -Sl ./elfutils-0.129/libelf/libelf.so output (4.72 KB, text/plain)
2007-10-05 04:48 EDT, Oliver Falk
no flags Details
eu-readelf on libelf/libelf.so with patched binutils to fix GNU_RELRO (4.72 KB, text/plain)
2007-10-23 14:05 EDT, Oliver Falk
no flags Details
elflint on addr2line (4.60 KB, text/plain)
2008-08-07 06:07 EDT, Oliver Falk
no flags Details
readelf -a on addr2line (25.75 KB, text/plain)
2008-08-07 06:08 EDT, Oliver Falk
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 5149 None None None Never

  None (edit)
Description Jakub Bogusz 2006-08-26 06:58:22 EDT
Description of problem:
elfutils 0.123 (and many earlier versions) don't pass testsuite on alpha platform.

How reproducible:
Build elfutils, cd to "tests" directory and invoke "make check".

Additional info:
I made a patch which updates alpha platform support so that testsuite is passed:
http://cvs.pld-linux.org/SOURCES/elfutils-alpha.patch?rev=1.6
Comment 1 Jakub Bogusz 2006-08-26 06:59:52 EDT
Created attachment 134974 [details]
Update alpha platform support (for elfutils 0.123)

I'm attaching patch mentioned above.
Comment 2 Jakub Bogusz 2006-11-17 11:53:19 EST
Comment on attachment 134974 [details]
Update alpha platform support (for elfutils 0.123)

Patch updated for elfutils 0.124
Comment 3 Jakub Bogusz 2006-11-17 11:57:18 EST
Created attachment 141495 [details]
Update alpha platform support (for elfutils 0.124)

Aah. I hope this way updated patch would be attached.
Comment 4 Jakub Bogusz 2007-03-16 15:52:33 EDT
Created attachment 150275 [details]
Update alpha platform support (for elfutils 0.126)
Comment 5 Roland McGrath 2007-05-23 03:31:25 EDT
I think I have the alpha bits right upstream now.
Comment 6 Roland McGrath 2007-06-08 18:28:30 EDT
I believe alpha support is happy in 0.128 (on its way to rawhide, already in
fedora cvs).  Please verify.
Comment 7 Jakub Bogusz 2007-07-12 01:09:58 EDT
These issues are gone. But there is one new:

loadable segment GNU_RELRO applies to is executable
*** failure in ../libelf/libelf.so
FAIL: run-elflint-self.sh

(the same on sparc as I've been told)
Comment 8 Roland McGrath 2007-09-11 15:42:59 EDT
That is probably finding an ld bug (binutils).  Can you show me the eu-readelf
-Sl output on an object that elflint rejects?
Comment 9 Jakub Bogusz 2007-09-15 16:11:07 EDT
Created attachment 196521 [details]
Partial `eu-readelf -a addr2line` output on alpha
Comment 10 Jakub Bogusz 2007-09-15 16:12:30 EDT
Created attachment 196531 [details]
`eu-readelf -Sl libelf.so` output on alpha
Comment 11 Jakub Bogusz 2007-09-15 16:13:08 EDT
Created attachment 196541 [details]
`eu-readelf -Sl libelf.so` output on sparc
Comment 12 Jakub Bogusz 2007-09-15 16:14:01 EDT
Created attachment 196551 [details]
`eu-readelf -Sl libelf.so` output on sparc64
Comment 13 Jakub Bogusz 2007-09-15 16:19:40 EDT
Here are requested information dumps (from alpha, sparc and sparc64, on which
elflint-self test fails on libelf.so).
I also included a part of `eu-readelf -a addr2line` dump from alpha, as I got a
new elflint-self failure (on elfutils 0.129):
section [36] '.symtab': symbol 69: st_value out of bounds
section [36] '.symtab': symbol 88: st_value out of bounds
*** failure in ../src/addr2line

This might be related to binutils version... if it matters, I have
binutils-2.17.50.0.16 on alpha and binutils-2.17.50.0.8 on sparc.
Comment 14 Roland McGrath 2007-09-16 13:34:19 EDT
The elflint complaints look valid and the details in those objects are indeed
wrong.  You have one or more ld bugs here, and AFAICT no elfutils bugs.

The data segment is executable, which is not right unless Alpha's .plt is real
funny.  If the data should be executable, RELRO should not apply to that
segment, I think.  That one might be questionable.

The st_value complaints are valid, the data_start and __data_start symbols in
that output are outside the section they claim to be in.

Another suspect thing is the LOOS+84153728 phdrs, which look totally bogus (that
is not a valid p_type I know of, 0x65041580).
Comment 15 Roland McGrath 2007-10-04 16:39:17 EDT
*** Bug 318371 has been marked as a duplicate of this bug. ***
Comment 16 Oliver Falk 2007-10-05 04:47:05 EDT
elfutils-0.128 works just fine here:
elfutils-0.128-2.fc7
binutils-2.17.50.0.18-1
gcc-4.1.2-29

I attached the full and correct buildlog from my elfutils-0.129 to Bug #318371.

I'll attach

[oliver@gosa elfutils]$ eu-readelf -Sl ./elfutils-0.129/libelf/libelf.so > output

now; My output is different maybe it helps.
Comment 17 Oliver Falk 2007-10-05 04:48:13 EDT
Created attachment 217161 [details]
eu-readelf -Sl ./elfutils-0.129/libelf/libelf.so output
Comment 18 Roland McGrath 2007-10-09 17:51:49 EDT
The only issue remaining is the RELRO segment.  So far this appears to be a
correct diagnosis by elflint, and how it's produced is a bug in ld (binutils).
The same issue occurs on sparc.
Comment 19 Oliver Falk 2007-10-15 03:17:29 EDT
Roland, you think we should reassign this to binutils? I think Jakub will then
be the owner - isn't it? Or shall we just take binutils maintainer CC:?

The strange thing to me is, that I cannot even recompile the old elfutils. I
start to think this has something to do with the new --hash-style option!?
Comment 20 Roland McGrath 2007-10-15 03:50:11 EDT
This report has already been overloaded talking about a few different problems,
all of which have been fixed in elfutils.  It is time to close it.

The RELRO complaint is not an elfutils bug.  The DSO layout under -z relro may
well be an ld bug.  File a bug for binutils about that.

Whatever compilation issues you are having are yet a third issue, and probably
not something for a Fedora bugzilla report at all.
Comment 21 Oliver Falk 2007-10-15 04:07:42 EDT
OK Roland. Will bug other place then :-)
Comment 22 Oliver Falk 2007-10-23 11:07:36 EDT
Roland, the binutils bug should be fixed now, with the patch mentioned here:
http://sourceware.org/bugzilla/show_bug.cgi?id=5149

But elfutils still spots that error :-(
Comment 23 Roland McGrath 2007-10-23 11:53:12 EDT
Can you attach the new eu-readelf -Sl output?
Comment 24 Oliver Falk 2007-10-23 14:05:12 EDT
Created attachment 235321 [details]
eu-readelf on libelf/libelf.so with patched binutils to fix GNU_RELRO

Sure. Output attached.
Comment 25 Oliver Falk 2007-11-05 06:02:59 EST
H.J. Lu thinks that there now is a bug in elflint; I have already created a link
to sourceware, so you can easily check...
Comment 26 Bug Zapper 2008-04-03 14:02:35 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 27 Oliver Falk 2008-04-04 03:30:36 EDT
This bug is still true for f8, f9/rawhide. I see sparc listed in the no test
section of elfutils. Maybe we should do this with alpha as well, as it doesn't
seem to *break* anything atm.
Comment 28 Roland McGrath 2008-04-04 16:26:15 EDT
Things are just all fixed for sparc as of the next release (0.134).
I'd rather see things get fixed for alpha.
Comment 29 Oliver Falk 2008-04-06 14:48:14 EDT
Where can I get a copy of 0.134 alpha, beta, rc0 rc1, whatever ? :-)
Comment 30 Oliver Falk 2008-04-10 05:20:15 EDT
0.134 still generates the same error:
<snip>
PASS: run-elflint-test.sh
section [38] '.symtab': symbol 66: st_value out of bounds
section [38] '.symtab': symbol 85: st_value out of bounds
*** failure in ../src/addr2line
FAIL: run-elflint-self.sh
<snip>
</snap>
=====================================================
1 of 66 tests failed
Please report to http://bugzilla.redhat.com/bugzilla/
=====================================================
make[3]: *** [check-TESTS] Error 1
make[2]: *** [check-am] Error 2
make[1]: *** [check-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.70371 (%check)
</snap>
Comment 31 Roland McGrath 2008-04-11 15:39:25 EDT
That is not the error we were talking about.  The st_value complaints are valid
diagnosis of an ld (binutils) bug, AFAIK.
Comment 32 Oliver Falk 2008-04-15 04:25:57 EDT
So. What are the further steps. Disable testing on alpha or is anybody able to
fix the problem. AFAICS, it doesn't make problems if you disable testing and use
elfutils...
Comment 33 Roland McGrath 2008-04-15 04:50:35 EDT
Attach eu-readelf -a output along with the eu-elflint errors from any object
still failing.  Then we can verify if the "out of bounds" error is a correct
diagnosis of an ld bug.
Comment 34 Bug Zapper 2008-05-13 22:18:16 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 35 Fedora Update System 2008-05-21 15:48:53 EDT
elfutils-0.135-1.fc7 has been submitted as an update for Fedora 7
Comment 36 Fedora Update System 2008-05-21 15:51:27 EDT
elfutils-0.135-1.fc8 has been submitted as an update for Fedora 8
Comment 37 Fedora Update System 2008-05-21 15:53:00 EDT
elfutils-0.135-1.fc9 has been submitted as an update for Fedora 9
Comment 38 Fedora Update System 2008-05-28 22:39:45 EDT
elfutils-0.135-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update elfutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-4457
Comment 39 Fedora Update System 2008-07-30 16:08:32 EDT
elfutils-0.135-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 Fedora Update System 2008-07-30 16:11:39 EDT
elfutils-0.135-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 41 Oliver Falk 2008-08-07 06:07:52 EDT
Created attachment 313674 [details]
elflint on addr2line
Comment 42 Oliver Falk 2008-08-07 06:08:23 EDT
Created attachment 313675 [details]
readelf -a on addr2line
Comment 43 Oliver Falk 2008-08-07 06:12:50 EDT
Seems to get worse :-(
Comment 44 Roland McGrath 2008-08-07 16:23:48 EDT
Running from your build tree requires LD_LIBRARY_PATH=libelf:libdw:backends.
Please show the elflint output when it gets the right backend library.
Comment 45 Roland McGrath 2008-08-07 16:26:07 EDT
Also note the run-elflint-self.sh test passes --gnu-ld to elflint.
Comment 46 Oliver Falk 2008-08-07 16:42:37 EDT
Already guess something must be wrong. :-( Sorry.

[oliver@kriek elfutils-0.135]$ LD_LIBRARY_PATH=libelf:libdw:backends src/elflint --gnu-ld src/addr2line
section [37] '.symtab': symbol 65: st_value out of bounds
section [37] '.symtab': symbol 84: st_value out of bounds

The readelf output should be fine, right?
Comment 47 Roland McGrath 2008-08-07 18:09:38 EDT
The situation is the same as before.  Those two errors are about data_start and __data_start, which are two symbols with the same value/section (aliases defined together).  It looks like there is an ld bug here.  The st_value of data_start is not plausible.  It's supposed to be the beginning of .data, but there is no .data section at all.  If there were, I'm sure it would have st_align=8, so that would not be its address.  Somehow these symbols have ended up pointing to the .got section but with an address that's 4 bytes before .got (and thus misaligned).
Comment 48 Oliver Falk 2008-08-08 04:09:24 EDT
Roland. Fine, it seems an ld bug, I don't even want to think about what an ld bug on alpha platform might imply... :-(

However. I don't have any 'good contacts' to binutils guys. So do you have?
fyi. The binutils version I used for this test: 2.18.50.0.8 (rawhide rpm).
Comment 49 Roland McGrath 2008-08-08 17:01:13 EDT
Just post to bug-binutils about the problem.  You can CC me and I'll be happy to explain the details I've seen further.  What I've already told you should be clear to ld hackers.  As to finding one who wants to fix alpha, good luck.
Comment 50 Oliver Falk 2008-08-13 05:45:02 EDT
(In reply to comment #49)
> Just post to bug-binutils about the problem.  You can CC me and I'll be happy
> to explain the details I've seen further.  What I've already told you should be
> clear to ld hackers.  As to finding one who wants to fix alpha, good luck.

Sent a mail to the list, but no reaction yet.
Comment 51 Bug Zapper 2008-11-25 20:50:05 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 52 Roland McGrath 2009-07-23 15:38:51 EDT
These bugs are fixed in current Fedora 10/11 updates of elfutils.

Note You need to log in before you can comment on or make changes to this bug.