Bug 2041932 - F35: SELinux is preventing tumblerd from write access on the sock_file bus.
Summary: F35: SELinux is preventing tumblerd from write access on the sock_file bus.
Keywords:
Status: CLOSED DUPLICATE of bug 2042696
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-01-18 14:51 UTC by Norbert Jurkeit
Modified: 2022-01-26 15:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-26 15:46:44 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Norbert Jurkeit 2022-01-18 14:51:51 UTC
Since upgrade to selinux-policy-35.9-1.fc35 I receive 3 SELinux alerts at login to Xfce desktop:

1: SELinux is preventing lightdm-gtk-gre from write access on the sock_file bus.

2: SELinux is preventing tumblerd from write access on the sock_file bus.

3: SELinux is preventing systemd-user-ru from unlink access on the sock_file bus.

Alerts No. 1 and 3 are fixed with selinux-policy-35.10-1.fc35 (currently in updates-testing), but alert No. 2 remains. It is quite pesky because it occurs not only at login but also each time Thunar (Xfce file manager) is launched or some file operation is performed with Thunar.

Similar reports related to Fedora 34 and 36: bug 2041243, bug 2041085 and bug 2039546.

Comment 1 Norbert Jurkeit 2022-01-20 10:23:56 UTC
Alert No. 2 persists also with selinux-policy-35.11-1.fc35.

Comment 2 Zdenek Pytela 2022-01-26 15:46:44 UTC

*** This bug has been marked as a duplicate of bug 2042696 ***


Note You need to log in before you can comment on or make changes to this bug.