Bug 204198 - stage1/cc1: corrupted double-linked list: 0x0c2015e8
stage1/cc1: corrupted double-linked list: 0x0c2015e8
Status: CLOSED DUPLICATE of bug 203765
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-26 12:20 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 15:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/ccDBQTnb.out as bzip2 compressed data (144.54 KB, application/octet-stream)
2006-08-26 12:24 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2006-08-26 12:20:34 EDT
Description of problem:
stage1/xgcc -Bstage1/ -B/usr/i386-redhat-linux/bin/   -O2 -g -pipe -Wall -
fexceptions -fstack-protector --param=ssp-buffer-size=4 -march=i386 -
mtune=generic -fasynchronous-unwind-tables -fprofile-generate -DIN_GCC   -W -
Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -ped
antic -Wno-long-long -Wno-variadic-macros -Wold-style-definition -Wmissing-
format-attribute     -DHAVE_CONFIG_H  gcov-dump.o version.o errors.o
 ../libcpp/libcpp.a   ../libiberty/libiberty.a -o gcov-dump
*** glibc detected *** stage1/cc1: corrupted double-linked list: 0x0c2015e8 ***
======= Backtrace: =========
/lib/libc.so.6[0x4008a53a]
/lib/libc.so.6[0x4008c61d]
/lib/libc.so.6(__libc_calloc+0x8d)[0x4008deed]
stage1/cc1[0x857e9cc]
stage1/cc1[0x816907a]
stage1/cc1[0x80fa02b]
stage1/cc1[0x84371d9]
stage1/cc1[0x8437298]
stage1/cc1[0x84372b4]
stage1/cc1[0x80c8986]
stage1/cc1[0x805886e]
stage1/cc1[0x84891aa]
stage1/cc1[0x8489349]
stage1/cc1[0x8489966]
stage1/cc1[0x805aade]
stage1/cc1[0x840d792]
stage1/cc1[0x840ee7f]
stage1/cc1[0x840eee1]
stage1/cc1[0x80b20da]
/lib/libc.so.6(__libc_start_main+0xdc)[0x4003c23c]
stage1/cc1[0x8049981]
======= Memory map: ========
08048000-08648000 r-xp 00000000 68:02 2377163    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/stage1/cc1
08648000-0864d000 rwxp 005ff000 68:02 2377163    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/stage1/cc1
0864d000-086cf000 rwxp 0864d000 00:00 0
0a683000-0c866000 rwxp 0a683000 00:00 0          [heap]
3ffff000-40000000 r-xp 3ffff000 00:00 0          [vdso]
40000000-40019000 r-xp 00000000 68:02 2965546    /lib/ld-2.4.90.so
40019000-4001a000 r-xp 00018000 68:02 2965546    /lib/ld-2.4.90.so
4001a000-4001b000 rwxp 00019000 68:02 2965546    /lib/ld-2.4.90.so
4001b000-40022000 rwxp 4001b000 00:00 0
40023000-4015a000 r-xp 00000000 68:02 2965585    /lib/libc-2.4.90.so
4015a000-4015c000 r-xp 00137000 68:02 2965585    /lib/libc-2.4.90.so
4015c000-4015d000 rwxp 00139000 68:02 2965585    /lib/libc-2.4.90.so
4015d000-408e9000 rwxp 4015d000 00:00 0
408ea000-40d10000 rwxp 408ea000 00:00 0
40d11000-41411000 rwxp 40d11000 00:00 0
41411000-41460000 rwxp 40cea000 00:00 0
41460000-47949000 rwxp 41460000 00:00 0
47949000-47954000 r-xp 00000000 68:02 2377178    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/libgcc_s.so.1
47954000-47955000 rwxp 0000a000 68:02 2377178    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/libgcc_s.so.1
479c6000-494c6000 rw-p 479c6000 00:00 0
49500000-49521000 rw-p 49500000 00:00 0
49521000-49600000 ---p 49521000 00:00 0
bfec9000-bfef9000 rw-p bfec9000 00:00 0          [stack]
../../gcc/config/i386/i386.md: In function 'internal_dfa_insn_code':
../../gcc/config/i386/i386.md:27172: internal compiler error: Aborted
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
*** glibc detected *** stage1/cc1: corrupted double-linked list: 0x0be03ec8 ***
======= Backtrace: =========
/lib/libc.so.6[0x4008a53a]
/lib/libc.so.6[0x4008c61d]
/lib/libc.so.6(__libc_calloc+0x8d)[0x4008deed]
stage1/cc1[0x857e9cc]
stage1/cc1[0x816907a]
stage1/cc1[0x80fa02b]
stage1/cc1[0x84371d9]
stage1/cc1[0x8437298]
stage1/cc1[0x84372b4]
stage1/cc1[0x80c8986]
stage1/cc1[0x805886e]
stage1/cc1[0x84891aa]
stage1/cc1[0x8489349]
stage1/cc1[0x8489966]
stage1/cc1[0x805aade]
stage1/cc1[0x840d792]
stage1/cc1[0x840ee7f]
stage1/cc1[0x840eee1]
stage1/cc1[0x80b20da]
/lib/libc.so.6(__libc_start_main+0xdc)[0x4003c23c]
stage1/cc1[0x8049981]
======= Memory map: ========
08048000-08648000 r-xp 00000000 68:02 2377163    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/stage1/cc1
08648000-0864d000 rwxp 005ff000 68:02 2377163    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/stage1/cc1
0864d000-086cf000 rwxp 0864d000 00:00 0
0a315000-0c4f8000 rwxp 0a315000 00:00 0          [heap]
3ffff000-40000000 r-xp 3ffff000 00:00 0          [vdso]
40000000-40019000 r-xp 00000000 68:02 2965546    /lib/ld-2.4.90.so
40019000-4001a000 r-xp 00018000 68:02 2965546    /lib/ld-2.4.90.so
4001a000-4001b000 rwxp 00019000 68:02 2965546    /lib/ld-2.4.90.so
4001b000-40022000 rwxp 4001b000 00:00 0
40023000-4015a000 r-xp 00000000 68:02 2965585    /lib/libc-2.4.90.so
4015a000-4015c000 r-xp 00137000 68:02 2965585    /lib/libc-2.4.90.so
4015c000-4015d000 rwxp 00139000 68:02 2965585    /lib/libc-2.4.90.so
4015d000-408e9000 rwxp 4015d000 00:00 0
408ea000-40d10000 rwxp 408ea000 00:00 0
40d11000-41411000 rwxp 40d11000 00:00 0
41411000-41460000 rwxp 40cea000 00:00 0
41460000-47949000 rwxp 41460000 00:00 0
47949000-47954000 r-xp 00000000 68:02 2377178    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/libgcc_s.so.1
47954000-47955000 rwxp 0000a000 68:02 2377178    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/libgcc_s.so.1
479c6000-494c6000 rw-p 479c6000 00:00 0
49500000-49521000 rw-p 49500000 00:00 0
49521000-49600000 ---p 49521000 00:00 0
bf804000-bf834000 rw-p bf804000 00:00 0          [stack]
*** glibc detected *** stage1/cc1: corrupted double-linked list: 0x0b4d0ec8 ***
======= Backtrace: =========
/lib/libc.so.6[0x4008a53a]
/lib/libc.so.6[0x4008c61d]
/lib/libc.so.6(__libc_calloc+0x8d)[0x4008deed]
stage1/cc1[0x857e9cc]
stage1/cc1[0x816907a]
stage1/cc1[0x80fa02b]
stage1/cc1[0x84371d9]
stage1/cc1[0x8437298]
stage1/cc1[0x84372b4]
stage1/cc1[0x80c8986]
stage1/cc1[0x805886e]
stage1/cc1[0x84891aa]
stage1/cc1[0x8489349]
stage1/cc1[0x8489966]
stage1/cc1[0x805aade]
stage1/cc1[0x840d792]
stage1/cc1[0x840ee7f]
stage1/cc1[0x840eee1]
stage1/cc1[0x80b20da]
/lib/libc.so.6(__libc_start_main+0xdc)[0x4003c23c]
stage1/cc1[0x8049981]
======= Memory map: ========
08048000-08648000 r-xp 00000000 68:02 2377163    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/stage1/cc1
08648000-0864d000 rwxp 005ff000 68:02 2377163    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/stage1/cc1
0864d000-086cf000 rwxp 0864d000 00:00 0
099e2000-0bbc5000 rwxp 099e2000 00:00 0          [heap]
3ffff000-40000000 r-xp 3ffff000 00:00 0          [vdso]
40000000-40019000 r-xp 00000000 68:02 2965546    /lib/ld-2.4.90.so
40019000-4001a000 r-xp 00018000 68:02 2965546    /lib/ld-2.4.90.so
4001a000-4001b000 rwxp 00019000 68:02 2965546    /lib/ld-2.4.90.so
4001b000-40022000 rwxp 4001b000 00:00 0
40023000-4015a000 r-xp 00000000 68:02 2965585    /lib/libc-2.4.90.so
4015a000-4015c000 r-xp 00137000 68:02 2965585    /lib/libc-2.4.90.so
4015c000-4015d000 rwxp 00139000 68:02 2965585    /lib/libc-2.4.90.so
4015d000-408e9000 rwxp 4015d000 00:00 0
408ea000-40d10000 rwxp 408ea000 00:00 0
40d11000-41411000 rwxp 40d11000 00:00 0
41411000-41460000 rwxp 40cea000 00:00 0
41460000-47949000 rwxp 41460000 00:00 0
47949000-47954000 r-xp 00000000 68:02 2377178    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/libgcc_s.so.1
47954000-47955000 rwxp 0000a000 68:02 2377178    /usr/src/rpm/BUILD/gcc-4.1.1-
20060825/obj-i386-redhat-linux/gcc/libgcc_s.so.1
479c6000-494c6000 rw-p 479c6000 00:00 0
49500000-49521000 rw-p 49500000 00:00 0
49521000-49600000 ---p 49521000 00:00 0
bfe71000-bfe9e000 rw-p bfe71000 00:00 0          [stack]
Preprocessed source stored into /tmp/ccDBQTnb.out file, please attach this to 
your bugreport.
make[2]: *** [insn-attrtab.o] Error 1
make[2]: Leaving directory `/usr/src/rpm/BUILD/gcc-4.1.1-20060825/obj-i386-
redhat-linux/gcc'
make[1]: *** [stageprofile_build] Error 2
make[1]: Leaving directory `/usr/src/rpm/BUILD/gcc-4.1.1-20060825/obj-i386-
redhat-linux/gcc'
make: *** [profiledbootstrap] Error 2

Version-Release number of selected component (if applicable):
gcc-4.1.1-19

How reproducible:
Everytime, see below.

Steps to Reproduce:
I'm trying to build gcc-4.1.1-19 using gcc-4.1.1-18 and glibc-2.4.90-23, system 
is a i686 smp machine.

Actual results:
Errors like "corrupted double-linked list".

Expected results:
Building without any error.
Comment 1 Robert Scheck 2006-08-26 12:24:25 EDT
Created attachment 134980 [details]
/tmp/ccDBQTnb.out as bzip2 compressed data
Comment 2 Jakub Jelinek 2006-08-26 15:10:26 EDT

*** This bug has been marked as a duplicate of 203765 ***
Comment 3 Robert Scheck 2006-08-26 21:50:03 EDT
Maybe a dumb question, but how is OpenSceneGraph from Fedora Extras related to 
this bug report? I would say, this is either a bug in gcc/g++ or in glibc...

Note You need to log in before you can comment on or make changes to this bug.