Bug 204232 - js.spec generating invalid libjs.pc file
js.spec generating invalid libjs.pc file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: js (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
: 204236 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 09:05 EDT by Andy Kwong
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 05:24:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
change $ to % in the part generating libjs.pc (373 bytes, patch)
2006-08-27 09:05 EDT, Andy Kwong
no flags Details | Diff

  None (edit)
Description Andy Kwong 2006-08-27 09:05:26 EDT
Description of problem:

js.spec has a error in which there are $ in place of % in the part which
generates the libjs.pc file. Still occurs in js-devel-1.5-5.fc5.

How reproducible:

Always

Steps to Reproduce:
1. Install js-devel
2. Run pkg-config --list-all
3. See error message (variable _prefix undefined)
4. cat /usr/lib/pkgconfig/libjs.pc
5. See the ${_prefix}, ${_libdir} and ${_includedir} in file.
  
Actual results:
${_prefix}, ${_libdir} and ${_includedir} in /usr/lib/pkgconfig/libjs.pc

Expected results:
/usr, /usr/lib and /usr/include should be in /usr/lib/pkgconfig/libjs.pc

Additional info:

Attached a patch to js.spec to fix the issue.
Comment 1 Andy Kwong 2006-08-27 09:05:26 EDT
Created attachment 134996 [details]
change $ to % in the part generating libjs.pc
Comment 2 Matthias Saou 2006-08-28 04:17:47 EDT
*** Bug 204236 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Saou 2006-08-28 05:24:31 EDT
Thanks for the catch. Packages for FC-4, FC-5 and devel have been rebuilt and
should be available after the next push.

Note You need to log in before you can comment on or make changes to this bug.