Bug 204260 - kernel-2.6.17 unable to boot Promise FastTrack RAID array
kernel-2.6.17 unable to boot Promise FastTrack RAID array
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-27 17:34 EDT by Ronald Cole
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: parted-1.7.1-15.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 09:39:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2006-08-27 17:34:11 EDT
Description of problem:
nash unable to boot a Promise FastTrack RAID array with Fedora kernel > 2.6.16

Version-Release number of selected component (if applicable):
parted-1.6.25-8

How reproducible:
always

Steps to Reproduce:
1. install FC5 on a system with a Promise FastTrack RAID array and run pup to
upgrade to a kernel > 2.6.16
2.
3.
  
Actual results:
system hangs after printing the nash version

Expected results:
system to boot as it did after installing FC5

Additional info:
After consulting Bugzilla bugs 196556 and 196626, I grabbed
parted-1.7.1-9.1.src.rpm from the 5.91 development SRPMS directory and built it
and installed it.  Then I rebuilt mkinitrd-5.0.32-1 and reinstalled it. 
Finally, I remade the initrd*.img files and then I could boot a 2.6.17 kernel.

This has been broken for me for weeks and weeks and weeks!  Please consider
releasing a parted-1.7.1 errata for FC5, ASAP.
Comment 1 David Cantrell 2006-08-28 10:25:03 EDT
Thanks for the report and additional research.  That will save me some time. 
I'll get a parted-1.7.1 update out for FC-5, but you'll also need a new mkinitrd
(maybe).  You should open a bug for that and reference this bug.  The maintainer
of mkinitrd can determine if a new one needs to be released or not.
Comment 2 Fedora Update System 2006-08-28 13:22:53 EDT
parted-1.7.1-15.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Ronald Cole 2006-08-28 19:07:39 EDT
Yes, I already prodded bug 189708 to rebuild the current mkinitrd against
parted-1.7.1 when it's released.  I'll prod again when I see parted-1.7.1 arrive
as an update.
Comment 4 David Cantrell 2006-08-29 10:35:24 EDT
I pushed parted-1.7.1-15 to the FC-5 testing updates repository:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/5/

Please let me know if that one works for you and I'll move it to final.  The guy
who builds mkinitrd sits across from me, so I'll see if he can get an update out
for FC-5 soon.
Comment 5 Ronald Cole 2006-08-29 16:06:46 EDT
Works for me!
Comment 6 David Cantrell 2006-08-29 16:09:44 EDT
Moving to final.
Comment 7 Ronald Cole 2006-08-29 16:16:53 EDT
And rebuilding mkinitrd against this parted is essential.  And thanks for the
prompt response!  It's really appreciated!!
Comment 8 Fedora Update System 2006-08-29 16:45:42 EDT
parted-1.7.1-15.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 9 Jafaruddin Lie 2006-08-30 01:35:02 EDT
Excuse me for the dumb question, but how do I rebuild mkinitrd? 
Comment 10 David Cantrell 2006-08-30 10:42:12 EDT
Get the mkinitrd SRPM from FC5 or rawhide, and then do:

rpmbuild --rebuild name-of-src.rpm
Comment 11 Jafaruddin Lie 2006-08-31 08:44:20 EDT
No go.
I've rebuilt mkinitrd after installing parted-1.7.1-15 and parted-devel.
I then install the new mkinitrd rpm file using rpm -Uvh --force, reboot, still 
the same. 
Comment 12 Jason Smyth 2006-08-31 15:06:03 EDT
Re: Comment 11

Did you install the new kernel before or after updating to the new mkinitrd?

If before you will probably need to rebuild your kernel image file using the new
mkinitrd.

#mv /boot/initrd-2.6.17-1.2174_FC5.img /boot/initrd-2.6.17-1.2174_FC5.img.old
#mkinitrd /boot/initrd-2.6.17-1.2174_FC5.img 2.6.17-1.2174_FC5

If necessary, replace "2.6.17-1.2174_FC5" with the your kernel name.

Alternatively you could try uninstalling and then reinstalling the 2.6.17 kernel
package.
Comment 13 Jafaruddin Lie 2006-08-31 17:37:13 EDT
Ah thanks for that. It works now.
I did install the kernel before updating to the new mkinitrd.
A simple yum erase and yum install fixed it. All good now!!

Jafar - Happy now running kernel 2.6.17
Comment 14 Ronald Cole 2006-08-31 19:30:33 EDT
On my "everything installed" FC5, I can't rpm -U parted-1.7.1 because "pyparted"
depends on libparted-1.6.
Comment 15 Ronald Cole 2006-08-31 20:19:01 EDT
Never mind...  I see pyparted-1.7.3 in testing/5.  Maybe tomorrow with mkinitrd?
Keeping fingers crossed.
Comment 16 David Cantrell 2006-09-01 08:45:57 EDT
I've done updates for pyparted and mkinitrd.  Did those on Wednesday.  They are
both still sitting in testing/5 updates rather than final.  Releng will be
moving them to final updates soon.
Comment 17 David Cantrell 2006-09-01 09:39:12 EDT
parted, pyparted, and mkinitrd updates have all been pushed to FC5 updates
final.  The versions:

parted-1.7.1-15.fc5
pyparted-1.7.3-1.fc5
mkinitrd-5.0.32-2

Closing this report.  Thanks to all for testing!

Note You need to log in before you can comment on or make changes to this bug.