Bug 204274 - apparent memory leak in setroubleshootd
apparent memory leak in setroubleshootd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
: 205245 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 01:06 EDT by Valdis Kletnieks
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.49
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 12:19:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2006-08-28 01:06:57 EDT
Description of problem:
ps aux reports:

root      2424  2.1 52.6 1525452 407836 ?      Ssl  Aug27  11:42 /usr/bin/python
/usr/sbin/setroubleshootd

Disk light was on solid because system was thrashing - an 'su' to kill it took
over 2 minutes from hitting 'enter' to the Password: prompt. So no extensive
debugging was possible.

Version-Release number of selected component (if applicable):
setroubleshoot-0.37-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Dennis 2006-09-07 16:08:47 EDT
A very likely cause of memory leaks is our current use of libxml2. Unlike most
python object memory references are not automatically freed in libxml2. Once a
document is created it must be explicitly freed with doc.freeDoc() and xpath
contexts must be freed with ctxt.xpathFreeContext(). We create quite a few
documents (DOM trees) and search contexts, but we never explicitly free them. We
need to add these calls.
Comment 2 John Dennis 2006-09-07 16:10:43 EDT
*** Bug 205245 has been marked as a duplicate of this bug. ***
Comment 3 John Dennis 2006-10-03 12:19:22 EDT
This should be fixed in the current code base, we now free all libxml2 documents
and xpath contexts.

Note You need to log in before you can comment on or make changes to this bug.