Bug 205245 - Excessive memory consumption (leak?) by setroubleshootd
Excessive memory consumption (leak?) by setroubleshootd
Status: CLOSED DUPLICATE of bug 204274
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Depends On:
  Show dependency treegraph
Reported: 2006-09-05 11:39 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-07 16:10:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-09-05 11:39:01 EDT
Description of problem:
top - 11:33:52 up 3 days, 20:30,  4 users,  load average: 1.34, 1.03, 0.43
Tasks: 137 total,   3 running, 131 sleeping,   0 stopped,   3 zombie
Cpu(s): 63.1% us,  8.3% sy,  0.0% ni, 20.6% id,  6.0% wa,  2.0% hi,  0.0% si, 
0.0% st
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 1589 root      16   0  797m 380m 1964 S  0.0 43.0   5:01.35 setroubleshootd   

Looks like a memory leak.  I don't know the precise policy for when garbage
collection happens in Python, though, maybe it's waiting for that instead?

Version-Release number of selected component (if applicable):

How reproducible:
Unknown; this was the result on returning to the machine, having left it up over
a long weekend.  The box is serving a web site, and there's a cronjob for
backups, so there would have been some latent activity on the box over that time.

Additional info:
An "AVC denial, click icon to view" notification is visible, but no SELinux icon
is visible in the notification area, so I can't click on it (do you want me to
file this as a separate bug?)
Comment 1 John Dennis 2006-09-07 16:10:40 EDT

*** This bug has been marked as a duplicate of 204274 ***

Note You need to log in before you can comment on or make changes to this bug.