Bug 204435 - dangling symlinks in debuginfo packages
dangling symlinks in debuginfo packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
http://errata.devel.redhat.com/errata...
:
: 204437 (view as bug list)
Depends On:
Blocks: 205248 205251 205339 205500 205501 205503 205505
  Show dependency treegraph
 
Reported: 2006-08-28 23:44 EDT by Jindrich Novy
Modified: 2013-07-02 19:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-15 08:14:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jindrich Novy 2006-08-28 23:44:17 EDT
Description of problem:
Brew built debuginfo packages contain symlinks pointing directly to brew buildtree.

Consider the latest netpbm debuginfo package, which contains:
bmp.h -> /builddir/build/BUILD/netpbm-10.34/converter/bmp.h
(netpbm-debuginfo-10.34-4.fc6)

The dangling symlinks are pointing to C header files whose are included from
local sources by #include "*.h" but they aren't present in the directory where
are the sources, but in a different directory.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. build netpbm with brew
2.
3.
  
Actual results:
Dangling symlinks present in the debuginfo package

Expected results:
No dangling symlinks

Additional info:
Comment 1 Mike McLean 2006-09-05 12:55:42 EDT
I see that beehive suffers from a similar problem (bug 204437). I suspect that
this is an issue with the packages in the buildroots rather than brew itself (or
beehive for that matter).
Comment 2 Radek Bíba 2006-09-06 08:12:55 EDT
Custom-built debuginfo packages contain symlinks to the local buildroot, too
(e.g. /usr/src/redhat/BUILD/...). Is it a bug in rpmbuild or one of its
components, then?
Comment 3 Radek Bíba 2006-09-06 14:32:01 EDT
More than likely. Please see Joe Orton's proposed patch in attachment 135661 [details].
Comment 4 Radek Bíba 2006-09-06 14:37:26 EDT
*** Bug 204437 has been marked as a duplicate of this bug. ***
Comment 5 Radek Bíba 2006-09-06 15:46:28 EDT
I've gathered all the affected packages in current rawhide. Let's use this report
as a tracker bug and also to see the importance and impact of this issue.
Comment 7 Joe Orton 2006-11-15 08:14:27 EST
Confirmed fixed.

Note You need to log in before you can comment on or make changes to this bug.