Bug 204487 - xenU can't find root device
xenU can't find root device
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
: 216887 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-29 10:51 EDT by Edouard Bourguignon
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 17:19:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log of the xenU (4.08 KB, text/plain)
2006-08-29 10:51 EDT, Edouard Bourguignon
no flags Details
xenU configuration file (5.36 KB, application/octet-stream)
2006-08-29 10:52 EDT, Edouard Bourguignon
no flags Details
DomU boot log (4.76 KB, text/plain)
2006-08-31 05:15 EDT, Edouard Bourguignon
no flags Details

  None (edit)
Description Edouard Bourguignon 2006-08-29 10:51:00 EDT
Description of problem:

The xenU can't find the specified root device. Xen0 is a xen kernel with PAE
suppport (i don't know if it matters). 

Version-Release number of selected component (if applicable):

kernel-xen-2.6.17-1.2174_FC5

How reproducible:

static

Steps to Reproduce:
1. boot the xen0 domain
2. xm create xenU
  
Actual results:

The xenU boots and fails on this error:

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

The relevant options in the configuration file are:
disk = [ 'file:/DEVEL/Masters/2006/hd.img,hda1,w' ]
root = "/dev/hda1 ro"

this looks fine to me.

Expected results:

The disk image file specified in the xenU configuration should be detected and
mounted correctly

Additional info:

The server running the xen0 domain is an ibm x365 booting with the noapic boot
parameter (cf bug #204474).

As soon as the xenU has crashed, i can't start anymore any xenU. The error
message is:
Error: Device 769 (vbd) could not be connected. Backend device not found.

The only solution I found is a reboot. It's a bit annoying because x365 take a
very long time to boot (at least 8min)...

I will try with a xen0 kernel without PAE
Comment 1 Edouard Bourguignon 2006-08-29 10:51:00 EDT
Created attachment 135136 [details]
Boot log of the xenU
Comment 2 Edouard Bourguignon 2006-08-29 10:52:14 EDT
Created attachment 135138 [details]
xenU configuration file

based on the xmexample1 included in the kernel-xen package
Comment 3 Morgan Nilsson 2006-08-30 07:27:27 EDT
Adding ramdisk in domU config should work (works for me).
Comment 4 Edouard Bourguignon 2006-08-31 05:01:20 EDT
adding ramdisk in the domU config is worse, i can't even see the boot process,
it instantly failed on this error:

Using config file "/etc/xen/domU_pae".
Error: Device 769 (vbd) could not be connected. Backend device not found.

What is the device 769? seems to be something linked with disk access. It can't
read the ramdisk or if i comment the ramdisk definition in the config file, it
can't read the disk image of the root device.

thank you anyway, i appreciate your help

btw i found this bug #201764 to be quite similar with my problem (even if this
one concerns x86_64), i will try to make an initrd with xenblk preloaded as they
said
Comment 5 Edouard Bourguignon 2006-08-31 05:15:51 EDT
Created attachment 135270 [details]
DomU boot log
Comment 6 Edouard Bourguignon 2006-08-31 05:17:32 EDT
domU with xenblk preloaded in the initrd still failed to boot but with a
different error message

it can't find a /dev/root...
(cf Attachment #135270 [details])
Comment 7 Edouard Bourguignon 2006-09-06 10:28:52 EDT
it works perfectly on a xen0 kernel without PAE support

so there is a problem with the kernel-xen supporting PAE
Comment 8 Edouard Bourguignon 2006-09-11 05:35:28 EDT
and now, it works with a vanilla kernel built from xen source 3.0.2-2, same
machine, same config
domU boots perfectly, so there is a real problem with kernel-2.6.17-1_2174xen
package
Comment 9 Edouard Bourguignon 2006-11-08 05:32:07 EST
same problem on Fedora Core 6 kernel-xen package
Comment 10 Edouard Bourguignon 2006-11-09 05:13:35 EST
but works with an initrd preloading xenblk:

mkinitrd --omit-scsi-modules --preload=xenblk /boot/myinitrd.img `uname -r`

maybe domU try to access the real disk devices instead of the xen block devices
provided by the dom0. FYI this server has scsi disks with an adaptec ServeRaid
Comment 11 Stephen Tweedie 2006-11-09 17:19:23 EST
To get the initrd loading xenblk automatically,  it should have

alias scsi_hostadapter xenblk

in /etc/modprobe.conf.  This should be set up automatically on all installs;
it's only manually installing a PAE kernel-xen onto an existing non-PAE,
fc5-or-earlier kernel-xenU that will need the manual config step.
Comment 12 Stephen Tweedie 2006-11-22 10:37:52 EST
*** Bug 216887 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.