Bug 216887 - xenblk module is not preloaded in initrd on xen slices
xenblk module is not preloaded in initrd on xen slices
Status: CLOSED DUPLICATE of bug 204487
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 10:22 EST by Hiren Joshi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 10:37:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiren Joshi 2006-11-22 10:22:48 EST
Description of problem:
Updating DomU kernels to kernel-xen, the slice can no longer see the block
device on boot. I managed to get around this by running:
mkinitrd --preload=xenblk
and pointing to the new initrd before booting to the new kernel.

Now, I think it's mkinitrd run by the kernel-xen install script that failes to
notice the need for xenblk but just in case, I've ccd xen-maint in this.

Version-Release number of selected component (if applicable):


How reproducible:
Update a DomU kernel to kernel-xen, have a look at the initrd made, you should
notice the lack of xenblk. The slice will not boot up now.

Steps to Reproduce:
1. yum install kernel-xen
2.
3.
  
Actual results:
Slice does not "see" the block device and hence does not boot.

Expected results:
The slice should boot.

Additional info:
After the slice is back up you still need to --preload=xenblk to create the
right initrd (I've tried mkintrd and lloking at the init script, it does not
load the module) so I beleive the slice should break again on the next kernel
update.

I would imagine it's a trivial patch to mkinitrd to notice it's a xen (none
Dom0/DomU) kernel and preload the xenblk.

Let me know if you need any more info.

Thanks.
Comment 1 Stephen Tweedie 2006-11-22 10:37:36 EST
To update to kernel-xen, you need to add

alias scsi_hostadapter xenblk

to /etc/modprobe.conf to make this happen by default.  Anaconda will set this
automatically on FC-6 or later.

*** This bug has been marked as a duplicate of 204487 ***

Note You need to log in before you can comment on or make changes to this bug.