Bug 204519 - Weird desktop wide application focusing/cursor problem
Weird desktop wide application focusing/cursor problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
: 205074 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-29 15:02 EDT by Dennis Jacobfeuerborn
Modified: 2014-06-18 05:08 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 12:24:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2006-08-29 15:02:40 EDT
Since I fully resynced with yesterdays rawhide I now regulary lose the
cursor/ability to type in *any* application on the desktop. I can still focus a
window (ie the title bar changes it's color) but I cannot type anything in the
terminal or in gedit. Also when focusing a window I don't get any cursor (in
gedit it completely disappears, in the terminal the cursor is displayed as
"unfocused" i.e. as an unfilled rectangle). Also the menus can be selected and
get highlighted but the actual menu popup doesn't appear. Opera is affected too
so this doesn't seem to be limited to gtk2 apps.

Risizing a window (or at least clicking a border) fixes the problem until it
reappears a while later.

These are the package versions I have installed right now:
  metacity-2.15.34-1.fc6
  gtk2-2.10.2-3.fc6
  xorg-x11-server-Xorg-1.1.1-30.fc6
  kernel-2.6.17-1.2586.fc6 

I'm not sure if metacity is the right component for this bug so feel free to
reassign if necessary.
Comment 1 Joachim Frieben 2006-09-01 04:07:10 EDT
Right, the same here. In general, one manages to recover focus by
closing some window by clicking the [x] button or by opening a new
windows. Even menu buttons often get only highlighted, but no menu
opens. This happens on a current "rawhide" desktop. The issue is
probably 2-3 days old.
Btw, I have tried a current "Ubuntu" development live CD, and the
issue there shows up identically. So, it's not "Fedora" specific.
Comment 2 Matthias Clasen 2006-09-01 11:21:40 EDT
sounds like either the X server or metacity is getting confused about the
keyboard focus, probably metacity.
Comment 3 Ralf Ertzinger 2006-09-04 03:47:31 EDT
Me too.
My current "fix" is to hit Alt-Tab twice (which will select a different window,
and then back) to restore focus.
Comment 4 Pete Zaitcev 2006-09-04 12:53:41 EDT
*** Bug 205074 has been marked as a duplicate of this bug. ***
Comment 5 Joachim Frieben 2006-09-04 14:11:09 EDT
(In reply to comment #2)
After downgrading to "metacity-2.15.5-6.1" of "FC6T2", all focus
weirdness stops. It is thus clearly not the "X" server but rather
the window manager which is to blame.
Comment 6 Pete Zaitcev 2006-09-04 15:40:11 EDT
No need to go that far. I verified that 2.15.21-1.fc6 works (I lifted the
old binary RPM from Brew archive). Unfortunately, no releases between
.21 and .34 were packaged, so I cannot bisect further.
Comment 7 Joachim Frieben 2006-09-05 02:21:14 EDT
Sure, but in general, older "rawhide" packages are not accessible in most
cases once they have got supplanted by the latest version - in this case
the broken one. A clear advantage for Red Hat employees ;) I guess the best
is to simply archive all packages released between test releases on my hard
disk.
Comment 8 Matthias Clasen 2006-09-05 02:37:14 EDT
Pete, there were no releases between 2.15.21 and 2.15.34. Metacity does not
believe in consecutive release numbers.
Comment 9 Joachim Frieben 2006-09-05 08:48:36 EDT
Works for me again after upgrading to "metacity-2.16.0-1.fc6".
Comment 10 Matthias Clasen 2006-09-05 09:53:12 EDT
Thats odd, since there were no relevant changes between 2.15.34 and 2.16.0
Comment 11 Paul Dickson 2006-09-05 18:38:05 EDT
I updated to metacity-2.16.0-1.fc6 (via yum) and rebooted (to fixed the NFS
problems):

The problems seems more prevalent.  I hit it with the first use of
gnome-terminal.  It's still happening with Sylpheed (although double-clicking
does work).  Sylpheed seems to be hardest hit because of multiple windows
(possibly being created anew when switch message folders).
Comment 12 Paul Dickson 2006-09-05 19:40:11 EDT
The problem with gnome-terminal happens when gnome-session starts gnome-terminal
sessions.  Once you work around the focusing problem by clicking the blue drag
bar at the top, none of the remaining gnome-terminal windows have the problem.
Comment 13 Ralf Ertzinger 2006-09-06 07:34:48 EDT
I can confirm that the problem gets worse with metacity-2.16.0-1.fc6
Comment 14 Matthias Clasen 2006-09-07 23:56:48 EDT
Here is an upstream bug that may be relevant: 
http://bugzilla.gnome.org/show_bug.cgi?id=354422
Comment 15 Søren Sandmann Pedersen 2006-09-08 16:11:17 EDT
Question for people who have seen this: what settings do you use?
focus-follows-mouse, raise-on-click, etc?

Comment 16 Søren Sandmann Pedersen 2006-09-08 17:35:28 EDT
Ubuntu bug:

https://launchpad.net/distros/ubuntu/+source/metacity/+bug/57344
Comment 17 Michael Schwendt 2006-09-08 19:58:32 EDT
$ gconftool-2 -g /apps/metacity/general/focus_mode
sloppy
$ gconftool-2 -g /apps/metacity/general/focus_new_windows
smart
$ gconftool-2 -g /apps/metacity/general/auto_raise
true
$ gconftool-2 -g /apps/metacity/general/auto_raise_delay
687

Often affected here are Emacs, xterm, Sylpheed, Firefox.
Comment 18 Todd Mokros 2006-09-09 03:40:45 EDT
$ gconftool-2 -g /apps/metacity/general/focus_mode
sloppy
$ gconftool-2 -g /apps/metacity/general/focus_new_windows
smart
$ gconftool-2 -g /apps/metacity/general/auto_raise
false



Comment 19 Dennis Jacobfeuerborn 2006-09-09 09:02:34 EDT
focus_mode = click
focus_new_windows = smart
auto_raise = false
Comment 20 Joachim Frieben 2006-09-09 10:22:54 EDT
Actually using the same troublesome settings as in comment #18:
focus_mode: sloppy, focus_new_windows: smart, auto_raise false.
Comment 21 Elijah Newren 2006-09-09 16:27:47 EDT
There's a patch in http://bugzilla.gnome.org/show_bug.cgi?id=354422 that should
fix this; it was a race condition that always existed in metacity but became
much easier to trigger with the patch applied for upstream 126497.  Could people
test with that patch applied and verify whether that fixes the bug or whether
there might be more than one bug here?  It seems to fix it for me, but I can
reproduce very often at all...
Comment 22 Elijah Newren 2006-09-09 16:40:50 EDT
er, that should be *can't* reproduce very often at all...
Comment 23 Søren Sandmann Pedersen 2006-09-09 18:52:05 EDT
I ahve applied that patch to rawhide - it should show up tomorrow. In the
meantime I have put up the new packages here:

http://people.freedesktop.org/~sandmann/metacity-2.16.0-2.fc6/

Of course testing is appreciated. And thanks Elijah for providing the patch.
Comment 24 Paul Dickson 2006-09-10 08:44:51 EDT
I installed 2.16.0-2 from comment #23 and sylpheed no longer suffers from this
problem.

Thanks.
Comment 25 Michael Schwendt 2006-09-10 10:52:23 EDT
So far it seems as if 2.16.0-2 fixes the problem indeed. I haven't seen the
symptoms since I installed it.
Comment 26 Søren Sandmann Pedersen 2006-09-11 12:24:47 EDT
Alright, thanks for testing. Closing this bug.
Comment 27 Christopher Aillon 2006-09-11 13:42:45 EDT
I see this for gnome-terminal and firefox still....

% rpm -q firefox gnome-terminal metacity
firefox-1.5.0.6-12
gnome-terminal-2.16.0-1.fc6
metacity-2.16.0-1.fc6
Comment 28 Elijah Newren 2006-09-11 13:49:00 EDT
caillon: Upgrade, dude.  See comment 23-25, which says it seems to be fixed in
metacity version 2.16.0-*****2*****.fc6 (well, minus the stars used for
emphasis).  ;-)
Comment 29 Søren Sandmann Pedersen 2006-09-11 15:20:35 EDT
I had forgotten about the freeze, so the packages didn't actually show up in
rawhide. I have asked rel-eng to move them now though, so they should show up
tomorrow.

Comment 30 Pete Zaitcev 2006-09-21 15:31:41 EDT
metacity-2.16.0-2.fc6 fixed this for me as well. I didn't have the follow-up
problem for which Steven cloned this bug into bug 206263 -- despite the
pointer hardware acting funny on this D610.

Note You need to log in before you can comment on or make changes to this bug.