Bug 205074 - Focus is lost
Focus is lost
Status: CLOSED DUPLICATE of bug 204519
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-03 14:39 EDT by Pete Zaitcev
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 12:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2006-09-03 14:39:54 EDT
Description of problem:

I updated to metacity 2.15.34 yesterday and it seems having major issues
with my laptop. I have a touchpad which is somewhat screwy and generates
extra events sometimes. I know that it's broken, but until today it only
required a companion event. E.g. if middle button got stuck, I middle-button
again, and all is fine. But now, it's very, very hard to convince Metacity
to clear a paired event. I still do not have a failure-proof way to do it.

Version-Release number of selected component (if applicable):

metacity-2.15.34-1.fc6

How reproducible:

Not easily, you have to have hardware which unbalances events, e.g.
Middle down, Middle down, Middle up.

Steps to Reproduce:
1. On a certain hardware setup, work normally with a couple of
   terminals. Eventually it has to get stuck with the title bar
   changing to focus, but actual focus not getting to the application.

Actual results:

Unable to restore keyboard focus.

Expected results:

Keyboard input restoring when erroneous mouse events are cleared.

Additional info:

I'm afraid this is not something easy to reproduce elsewhere. So I'd like
someone to look at diffs between 2.15.21 and 2.15.34. The things to look
at is how Metacity compares events, and if anything was changed. But most
especially if someone decided to keep a counter instead of a flag for
mouse buttons.
Comment 1 Pete Zaitcev 2006-09-03 15:51:04 EDT
I see that I probably was wrong about counters.

The right recovery involves sending the second event where Metacity can see it.
In other words, if your middle button got stuck, middle button into the title
bar, and not anywhere else into the application.
Comment 2 Joachim Frieben 2006-09-04 03:32:24 EDT
This is a duplicate of bug 204519.
Comment 3 Pete Zaitcev 2006-09-04 12:53:28 EDT
nyorirooon....

*** This bug has been marked as a duplicate of 204519 ***

Note You need to log in before you can comment on or make changes to this bug.