Bug 204574 - FC5 ships an older device-mapper than FC4, breaks yum upgrade
FC5 ships an older device-mapper than FC4, breaks yum upgrade
Status: CLOSED DUPLICATE of bug 208533
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-30 01:16 EDT by Joe Buck
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 06:02:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Buck 2006-08-30 01:16:08 EDT
Description of problem:

I'm filing this against device-mapper, but it also applies to lvm2.

FC4 updates provides the following two packages:

device-mapper-1.02.07-2.0.i386.rpm
lvm2-2.02.06-1.0.fc4.i386.rpm

FC5 provides the following two packages:

device-mapper-1.02.02-3.2.i386.rpm
lvm2-2.02.01-1.2.1.i386.rpm

See the problem?  This causes breakage when upgrading an FC4 to an FC5
system.

Version-Release number of selected component (if applicable):

See above.

How reproducible:

Anyone trying to upgrade an FC4 system with yum will encounter problems
because of this.


Steps to Reproduce:
"yum upgrade" with an FC4 system; almost everyone will have device-mapper
  
Actual results:

Lots of conflicts; try to work around them by various combinations of package
removal and re-installation and "rpm --force".  Live with a corrupt RPM database.


Expected results:

A clean upgrade.  Yes, "yum upgrade" works cleanly if package maintainers
are careful to ensure that FCn+1 has versions that rpm/yum considers "newer"
than corresponding packages in FCn.


Additional info:

Please produce new versions of the device-mapper and lvm2 packages that have a
higher version number than any in FC4.  In particular, FC4 seems to have a newer
upstream version of device-mapper than FC5!  Why are you downgrading us?
Comment 1 Johan Kok 2006-09-29 06:02:58 EDT

*** This bug has been marked as a duplicate of 208533 ***

Note You need to log in before you can comment on or make changes to this bug.