Bug 204745 - gstreamer-0.10 engine support in amarok is broken again
gstreamer-0.10 engine support in amarok is broken again
Status: CLOSED DUPLICATE of bug 192802
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 08:27 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 10:41:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-08-31 08:27:26 EDT
Description of problem:

According to bug #192802 the gstreamer support was fixed, but in the most recent
version of amarok, it again does not appear as an engine that can be chosen


Version-Release number of selected component (if applicable):
amarok-1.4.2-1.fc5


How reproducible:
Always

Steps to Reproduce:
1. yum install amarok
2. go to "Engine" options

  
Actual results:
You only see the Helix engine

Expected results:
Helix and gstreamer should appear

Additional info:

Looking at the list of files in the package, it appears that it is missing
libamarok_gstreamerengine_plugin.so analogous to the
libamarok_helixengine_plugin.so:

$ rpm -ql amarok
/usr/bin/amarok
/usr/bin/amarok_daapserver.rb
/usr/bin/amarok_proxy.rb
/usr/bin/amarokapp
/usr/bin/amarokcollectionscanner
/usr/lib/kde3/konqsidebar_universalamarok.la
/usr/lib/kde3/konqsidebar_universalamarok.so
/usr/lib/kde3/libamarok_daap-mediadevice.la
/usr/lib/kde3/libamarok_daap-mediadevice.so
/usr/lib/kde3/libamarok_generic-mediadevice.la
/usr/lib/kde3/libamarok_generic-mediadevice.so
/usr/lib/kde3/libamarok_helixengine_plugin.la
/usr/lib/kde3/libamarok_helixengine_plugin.so
/usr/lib/kde3/libamarok_ifp-mediadevice.la
/usr/lib/kde3/libamarok_ifp-mediadevice.so
/usr/lib/kde3/libamarok_ipod-mediadevice.la
/usr/lib/kde3/libamarok_ipod-mediadevice.so
/usr/lib/kde3/libamarok_massstorage-device.la
/usr/lib/kde3/libamarok_massstorage-device.so
/usr/lib/kde3/libamarok_nfs-device.la
/usr/lib/kde3/libamarok_nfs-device.so
/usr/lib/kde3/libamarok_njb-mediadevice.la
/usr/lib/kde3/libamarok_njb-mediadevice.so
/usr/lib/kde3/libamarok_smb-device.la
/usr/lib/kde3/libamarok_smb-device.so
/usr/lib/kde3/libamarok_void-engine_plugin.la
/usr/lib/kde3/libamarok_void-engine_plugin.so
/usr/lib/libamarok.so
/usr/lib/libamarok.so.0
/usr/lib/libamarok.so.0.0.0

<snip>
Comment 1 Aurelien Bompard 2006-08-31 10:41:36 EDT
gstreamer is still disabled by Amarok upstream.

*** This bug has been marked as a duplicate of 192802 ***
Comment 2 Alex Lancaster 2006-08-31 10:44:57 EDT
(In reply to comment #1)
> gstreamer is still disabled by Amarok upstream.

Then what does this changelog refer to?  It seems to suggest that it was fixing
it (i.e. making it work):

* Wed Jul 19 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.4.1-3
- fix the gstreamer engine (wrong X-KDE-Amarok-framework-version)




Comment 3 Aurelien Bompard 2006-08-31 12:28:17 EDT
The gstreamer engine was added back on the x86_64 architecture only because
there was no other engine on this arch. I made a mistake adding it back, and
fixed it in the -3 release.

The presence of the gstreamer engine is Amarok in general is *not* fixable,
because it is *not* a bug, it's a QA decision.

Note You need to log in before you can comment on or make changes to this bug.