Bug 20476 - up2date RPM should create /var/spool/up2date
up2date RPM should create /var/spool/up2date
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 12:56 EST by Dax Kelson
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 12:56:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2000-11-07 12:56:24 EST
Currently, the up2date-gnome RPM has the "/var/spool/up2date" directory. 
If you are running a server with no GNOME or X, and only install up2date,
it when you try to run it, it will fail.

Traceback (innermost last):
  File "/usr/sbin/up2date", line 394, in ?
    main()
  File "/usr/sbin/up2date", line 377, in main
    sys.exit(batchRun(onlyList, pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 190, in batchRun
    if totalSize > up2date.freeDiskSpace():
  File "/usr/share/rhn/up2date/up2date.py", line 925, in freeDiskSpace
    dfInfo = os.statvfs(cfg.readEntry("storageDir"))
OSError: [Errno 2] No such file or directory: '/var/spool/up2date'

The fix:

Have the up2date RPM create/supply the /var/spool/up2date directory instead
of the up2date-gnome RPM.

Dax
Comment 1 Preston Brown 2000-11-28 11:36:28 EST
thanks for the report.  This has been fixed in a forthcoming errata release of
update agent due this week.
Comment 2 Preston Brown 2000-12-08 15:33:44 EST
*** Bug 21903 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.