Bug 204861 - yum: installonlyn.py:23:?:ImportError: cannot import name comparePoEVR
yum: installonlyn.py:23:?:ImportError: cannot import name comparePoEVR
Status: CLOSED DUPLICATE of bug 204778
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-31 18:14 EDT by Luigi Coppolino
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 21:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Luigi Coppolino 2006-08-31 18:14:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060830 Fedora/1.5.0.6-9 Firefox/1.5.0.6 pango-text

Description of problem:
Component: Software Updater
Summary: TB4de30c90 installonlyn.py:23:?:ImportError: cannot import name comparePoEVR

Traceback (most recent call last):
  File "/usr/sbin/pup", line 549, in ?
    main()
  File "/usr/sbin/pup", line 542, in main
    pup = PackageUpdater()
  File "/usr/sbin/pup", line 86, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 124, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 123, in doConfigSetup
    startupconf.pluginconfpath)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 227, in doPluginSetup
    plugin_types, confpath)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 128, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 169, in _importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 185, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/installonlyn.py", line 23, in ?
    from yum.packages import YumInstalledPackage, comparePoEVR
ImportError: cannot import name comparePoEVR


Version-Release number of selected component (if applicable):
yum-2.9.5-3

How reproducible:
Always


Steps to Reproduce:
1.yum update
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Jeremy Katz 2006-08-31 21:33:32 EDT

*** This bug has been marked as a duplicate of 204778 ***

Note You need to log in before you can comment on or make changes to this bug.