Bug 204902 - unable to generate PDF
unable to generate PDF
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: linuxdoc-tools (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-09-01 03:04 EDT by Kir Kolyshkin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.9.21-8.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-12 05:59:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kir Kolyshkin 2006-09-01 03:04:35 EDT
Description of problem:

I was not able to generate PDF from SGML using linuxdoc-tools (see exact error
below).

I found that the reason is Patch3 (last patch from bug #149588). Looks like it
doesn't work anymore with the latest tetex.

So what I did is I reverted that patch and applied the one suggested in Debian
bug #321998. It works for me, and I have also checked that by default DVI is
produced.

Version-Release number of selected component (if applicable):
$ rpm -q linuxdoc-tools tetex tetex-latex
linuxdoc-tools-0.9.21-6.2.1.1kk
tetex-3.0-20.FC5
tetex-latex-3.0-20.FC5


How reproducible:
always

Steps to Reproduce:
1. wget http://kir.vtx.ru/resume/resume8.sgml
2. linuxdoc -B latex -o pdf resume8.sgml

Actual results:
Processing file resume8.sgml
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.

(./resume8.tex (/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2004/02/16 v1.4f Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo)))
! Incomplete \ifnum; all text was ignored after line 5.
<inserted text>
                \fi
<*> \nonstopmode\input{resume8.tex}

! Emergency stop.
<*> \nonstopmode\input{resume8.tex}

No pages of output.
Transcript written on resume8.log.


Expected results:
Generated PDF 

Additional info:
Debian bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=321998
My fixed linuxdoc-tools srpm:
http://kir.vtx.ru/lj/linuxdoc-tools-0.9.21-6.2.1.1kk.src.rpm
Comment 1 Kir Kolyshkin 2006-09-01 03:07:35 EDT
This bug actually renders linuxdoc-tools unusable, thus raising the severity.
Comment 2 Kir Kolyshkin 2007-01-09 19:22:03 EST
Ughm, looks like nobody is interested in curing linuxdoc? Pity :(
Comment 3 Tim Waugh 2007-01-11 10:26:11 EST
Oops, sorry.  Fixed in 0.9.21-8.fc6.
Comment 4 Fedora Update System 2007-01-11 17:01:15 EST
linuxdoc-tools-0.9.21-8.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.