Bug 204907 - After last update yum fails
After last update yum fails
Status: CLOSED DUPLICATE of bug 204778
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 05:21 EDT by Kostyantyn Shchekotykhin
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 09:15:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kostyantyn Shchekotykhin 2006-09-01 05:21:46 EDT
Here is the message:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 183, in getOptionsConfig
    errorlevel=opts.errorlevel)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 123, in
doConfigSetup
    startupconf.pluginconfpath)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 227, in
doPluginSetup
    plugin_types, confpath)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 128, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 169, in
_importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 185, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/installonlyn.py", line 23, in ?
    from yum.packages import YumInstalledPackage, comparePoEVR
ImportError: cannot import name comparePoEVR
Comment 1 Kostyantyn Shchekotykhin 2006-09-01 06:22:17 EDT
rpm -qa | grep yum

yum-2.9.5-3
yum-updatesd-2.9.5-3
yumex-1.1.2-1.1.fc6
yum-metadata-parser-1.0-7.1.fc6
Comment 2 David Cartwright 2006-09-01 08:25:05 EDT
I have the same problem.

My output from rpm -qa | grep yum

yum-2.9.5-3
yum-metadata-parser-1.0-7.1.fc6
Comment 3 Kostyantyn Shchekotykhin 2006-09-01 09:05:55 EDT
It seems to me that developers have already commited a new version 2.9.5-4 that
indeed is an old version of yum

This one works with some deprecation warnings
http://redhat.download.fedoraproject.org/pub/fedora/linux/core/development/i386/os/Fedora/RPMS/yum-2.9.5-4.noarch.rpm

Comment 4 Jeremy Katz 2006-09-01 09:15:14 EDT

*** This bug has been marked as a duplicate of 204778 ***

Note You need to log in before you can comment on or make changes to this bug.