Bug 2049188 - rust-image-roll-1.6.0 is available
Summary: rust-image-roll-1.6.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-image-roll
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rémi Lauzier
QA Contact:
URL:
Whiteboard:
Depends On: 2054456
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-01 17:20 UTC by Upstream Release Monitoring
Modified: 2022-02-24 17:54 UTC (History)
3 users (show)

Fixed In Version: rust-image-roll-1.5.0-2.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-24 17:54:29 UTC
Type: ---


Attachments (Terms of Use)
Update to 1.6.0 (#2049188) (678 bytes, patch)
2022-02-20 18:19 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2022-02-01 17:20:36 UTC
Latest upstream release: 1.5.0
Current version/release in rawhide: 1.4.1-1.fc36
URL: https://crates.io/crates/image-roll

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/214403/

Comment 1 Upstream Release Monitoring 2022-02-01 17:20:53 UTC
Scratch build failed. Details bellow:

BuilderException: Build started, but failure happened during post build operations:
Command '['git', 'commit', '-a', '-m', 'Update to 1.5.0 (#2049188)']' returned non-zero exit status 1.

StdOut:
On branch rawhide
Your branch is up to date with 'origin/rawhide'.

Untracked files:
  (use "git add <file>..." to include in what will be committed)
	SRPMS/

nothing added to commit but untracked files present (use "git add" to track)


Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 226, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2022-02-01 17:41:40 UTC
the-new-hotness/release-monitoring.org's scratch build of rust-image-roll-1.4.1-1.fc34.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=82247842

Comment 3 Upstream Release Monitoring 2022-02-20 18:19:30 UTC
Latest upstream release: 1.6.0
Current version/release in rawhide: 1.4.1-1.fc36
URL: https://crates.io/crates/image-roll

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/214403/

Comment 4 Upstream Release Monitoring 2022-02-20 18:19:33 UTC
Created attachment 1862216 [details]
Update to 1.6.0 (#2049188)

Comment 5 Upstream Release Monitoring 2022-02-20 18:23:54 UTC
the-new-hotness/release-monitoring.org's scratch build of rust-image-roll-1.6.0-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=83086423

Comment 6 Fabio Valentini 2022-02-24 07:16:41 UTC
I think it should be possible to update image-roll at least to 1.5.0 now, the necessary changes for gtk-rs 0.15 support are part of this upstream commit - maybe the relevant parts of it (those not changing behaviour, but adapting to gtk API changes) can be backported to 1.5.0?
https://github.com/weclaw1/image-roll/commit/61b7a213227c60dd8bf34d1172271a96d5faa491

Comment 7 Rémi Lauzier 2022-02-24 09:06:45 UTC
I made the mistake to prepare the update to version 1.6.0 without verifying if there was some new dependency. ashpd will need zbus 2.0 to work. i could propose an older working version of ashpd if that is possible?
i upgrade image-roll to version 1.5.0 for f35 before that.

Comment 8 Rémi Lauzier 2022-02-24 09:14:49 UTC
notify-rust support zbus 2 in a new release. secret-service as support for zbus 2 in git.
For system76-keyboard-configurator, i didn't find that it need zbus but the tree is complex to read so i may have miss it somewhere.

Comment 9 Fabio Valentini 2022-02-24 09:40:43 UTC
I don't think we can package ashpd in the current state. Looking at its dependencies:
https://crates.io/crates/ashpd/0.2.2/dependencies

It requires both new packages for gdk(4)(wayland,x11) etc. *and* pre-releases of the libwayland* bindings, which we can't update yet.

But you can always "git revert" your changes for 1.6.0 in dist-git, because the new version hasn't been built yet.
Sticking with 1.5.0 and backporting the gtk 0.15 support is probably much easier than packaging ashpd right now.

Comment 10 Fedora Update System 2022-02-24 17:51:10 UTC
FEDORA-2022-14ea70e50b has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-14ea70e50b

Comment 11 Fedora Update System 2022-02-24 17:54:29 UTC
FEDORA-2022-14ea70e50b has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.