Bug 204922 - [si_LK] can't input a sinhala letter ooyanna
[si_LK] can't input a sinhala letter ooyanna
Status: CLOSED DUPLICATE of bug 206261
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Liang Zhang
: i18n
Depends On:
Blocks: FC6Blocker SCIM 205171
  Show dependency treegraph
 
Reported: 2006-09-01 08:53 EDT by Akira TAGOH
Modified: 2015-04-06 23:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 13:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test Cases (15.56 KB, text/plain)
2006-09-11 02:09 EDT, Tyronne Wickramarathne
no flags Details

  None (edit)
Description Akira TAGOH 2006-09-01 08:53:42 EDT
Description of problem:
it could be input in 0.1.0 with a key sequence oo, but not in 0.2.0. typing o
and oo looks no difference and always appears a sinhala letter oyanna.

Version-Release number of selected component (if applicable):
0.2.0-1.fc6

How reproducible:
always

Steps to Reproduce:
1.activate scim-sinhala on gedit say
2.type oo
3.
  
Actual results:
it displays ඔ (U+0D94)

Expected results:
it should displays ඕ (U+0D95)

Additional info:
I'm not a native speaker and it may be still likely that 0.1.0 was wrong
behavior. we need to confirm it to the language maintainer.
Comment 1 Satyabrata Maitra 2006-09-05 01:22:31 EDT
After discussing with Sinhala translator I got some info regarding this bug.

Definition of Second Modifier :

There is one term called second modifier which appear when any consonant is
combined with any dependent vowels consecutively 2 times, like suppose 'k' is a
consonant, and 'i' is a vowel so, now if if u want to write "kii" in that case
the letter 'i' is appearing 2 times consecutively with the consonant. in that
case the 2nd appearance of 'i' is called second modifier.

Example : For sinhala layout : 'kii' -> Not OK
          For samanala Layout : 'kii ' -> Not OK
          For Wijesekera Lyout : 'kii' -> OK
The RAWCODE for kii is : U0D9A + U0DD3, where the Unicode - U0DD3 is the Second
modifier, which is appearing properly if typed, seleting RAWCODE from the scim
table. 

There are More lists of combinations with 2nd Modifier, an I will attach it with
this bug soon after getting from translator. 
Comment 2 Leon Ho 2006-09-06 21:32:13 EDT
Quote from our language maintainer Tyronne:
"With having this bug almost over 90% of the Sinhala words cannot be written
properly.
 
But quite surprisingly this bug(Bug Id 204922)  does not exist in my RHEL4-U4.
Which has the latest scim-sinhala (built off the CVS sources) but old pango
(1.9.1) support. In my humble opinion I believe that this problem exists after
the latest pango update. Further, this problem does not appear in FC rawhide,
when you type in KDE, eg: kedit."

Tagoh-san or LingNing, will it be a pango problem?
Comment 3 Akira TAGOH 2006-09-06 23:17:19 EDT
hm, interesting. so Tyronne could confirm this issue with the latest CVS
snapshot of scim-sinhala on GNOME applications, but it didn't happen on KDE
applications, right?

it would be better to attach the screenshot and the testcases to see what's
correct looks and correct UTF-8 sequences.
Comment 4 Mayank Jain 2006-09-07 04:10:50 EDT
Hi all,

Tyronne & I just tested this with 
pango-1.14.3-1.fc6 and scim-sinhala-0.2.0-1.fc6 and the combination "kii" is 
working as expected in gedit (gedit-2.15.9-1.fc6).

Comment 5 Tyronne Wickramarathne 2006-09-07 12:09:46 EDT
(In reply to comment #3)
> hm, interesting. so Tyronne could confirm this issue with the latest CVS
> snapshot of scim-sinhala on GNOME applications, but it didn't happen on KDE
> applications, right?

yes, that's right. i've tried with the latest scm-sinhala snapshop. 
on KDE applications this bug does not exist. it works fine. but not in gnome.

you can try typing l+o+o sequence on Gedit and also on Kedit. what appears on
Gedit is wrong.

to view the correct output try the following unicode values
0DBD+0DDD

> it would be better to attach the screenshot and the testcases to see what's
> correct looks and correct UTF-8 sequences.

yes, will mail you this
Comment 6 Tyronne Wickramarathne 2006-09-11 02:09:33 EDT
Created attachment 135965 [details]
Test Cases
Comment 7 Leon Ho 2006-09-11 02:19:31 EDT
Look like it is a rendering engine problem if it works for old pango but not the
new pango. Reassign it to pango component.

LingNing, please put this to high priority on your list, as this is a gating
problem for Sinhala.
Comment 8 Caolan McNamara 2006-09-25 13:17:46 EDT

*** This bug has been marked as a duplicate of 206261 ***

Note You need to log in before you can comment on or make changes to this bug.