Bug 204961 - NFS gives I/O errors on large files
NFS gives I/O errors on large files
Status: CLOSED DUPLICATE of bug 204859
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
: Regression
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
Reported: 2006-09-01 15:02 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-01 16:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-09-01 15:02:06 EDT
Description of problem:
This is beeing seen on my HP Integrity servers.  It may not be ia64 specific but
that is all I have to test on right now.

Note that this blocks NFS installations.

This was originally seen during installation however I am able to reproduce the
root of the problem on a running system where I have installed the appropriate

simply trying to cat a large file that is mounted via nfs can reproduce this:

# ls -l stage2.img
-rw-r--r-- 1 root root 93577216 Sep  1 14:22 stage2.img
# cat stage2.img > /dev/null
cat: stage2.img: Input/output error

smaller files seem OK:
# ls -l boot.img
-rw-r--r-- 1 root root 28606464 Sep  1 14:30 boot.img
# cat boot.img > /dev/null
(no error seen)

We ran into this when doing intalls of rawhide and anaconda attempted to
loopback mount the stage2.img file.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. mkdir /mnt/bigpapi
2. mount bigpapi.boston.redhat.com:/vol/engineering/redhat /mnt/bigpapi
3. cat
/mnt/bigpapi/nightly/rawhide-20060901/development/ia64/os/images/stage2.img >

Actual results:
cat: stage2.img: Input/output error

Expected results:
should get no error

Additional info:
Comment 1 Prarit Bhargava 2006-09-01 15:07:16 EDT
Possibly related to some of the other installation weirdness we're seeing?
Comment 2 Doug Chapman 2006-09-01 15:20:53 EDT
I partly agree with prarit that this might be related to bug 204638 where we
were seenig random panics during NFS installs.  However, this particular aspect
of the bug just started with today's (0901) build and is 100% reproducable.  The
other problems were fairly random and I didn't hit them 100% of the time.

Comment 3 Bill Nottingham 2006-09-01 16:37:26 EDT

*** This bug has been marked as a duplicate of 204859 ***

Note You need to log in before you can comment on or make changes to this bug.