Bug 204859 - NFS is broken
NFS is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
: 204961 204963 205061 (view as bug list)
Depends On:
Blocks: FC6Test3Blocker
  Show dependency treegraph
 
Reported: 2006-08-31 18:08 EDT by Bill Nottingham
Modified: 2014-03-16 23:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 12:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes broken upstream patch. (654 bytes, text/x-patch)
2006-09-02 17:17 EDT, Steve Dickson
no flags Details

  None (edit)
Description Bill Nottingham 2006-08-31 18:08:11 EDT
Description of problem:

NFS is broken.

Version-Release number of selected component (if applicable):

2.6.17-1.2608.fc6

How reproducible:

Every time

Steps to Reproduce:
1. mount -t nfs curly.devel.redhat.com:/vol/engineering/devarchve /mnt
2. cd /mnt/redhat/devel/rawhide-latest/rawhide-latest/latest/x86_64/os/Fedora/RPMS 
3. rpm -qp *86.rpm
  
Actual results:

I/O errors! Bad reads!

Expected results:

Not that.

Additional info:

2600 works fine.
Comment 1 Bill Nottingham 2006-09-01 16:37:49 EDT
*** Bug 204961 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2006-09-01 16:37:57 EDT
*** Bug 204963 has been marked as a duplicate of this bug. ***
Comment 3 Steve Dickson 2006-09-02 17:03:11 EDT
Backing out the following fixes the problem... I'm still
looking into what the next step should be... 


commit 79558f3610efd7928e8882b2eaca3093b283630e
tree 125f16640cd7f9de2074dae89a9c6c405703029c
parent 01df9c5e918ae5559f2d96da0143f8bfbb9e6171
author Trond Myklebust <Trond.Myklebust@netapp.com> Tue, 22 Aug 2006 21:44:32 -0400
committer Trond Myklebust <Trond.Myklebust@netapp.com> Thu, 24 Aug 2006 23:51:08
-0400

NFS: Fix issue with EIO on NFS read

The problem is that we may be caching writes that would extend the file and
create a hole in the region that we are reading. In this case, we need to
detect the eof from the server, ensure that we zero out the pages that
are part of the hole and mark them as up to date.

Signed-off-by: Trond Myklebust <Trond.Myklebust@netapp.com>
(cherry picked from 856b603b01b99146918c093969b6cb1b1b0f1c01 commit)
Comment 4 Steve Dickson 2006-09-02 17:17:17 EDT
Created attachment 135435 [details]
Patch that fixes broken upstream patch.

After further review, it appears the upstream patch in comment #3
did not get applied correctly.. This is the reason only rawhide kernels
are seeing this problem... Applying this patch will correct the patch as
well as fix the EIO errors.
Comment 6 Joe Orton 2006-09-04 05:29:25 EDT
*** Bug 205061 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2006-09-05 12:57:14 EDT
should be fixed in todays rawhide

Note You need to log in before you can comment on or make changes to this bug.