Bug 204963 - Input/output error: possible circular locking dependency detected
Input/output error: possible circular locking dependency detected
Status: CLOSED DUPLICATE of bug 204859
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-01 15:03 EDT by Benjamin Reed
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 16:37:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (9.39 KB, application/x-gzip)
2006-09-01 15:03 EDT, Benjamin Reed
no flags Details

  None (edit)
Description Benjamin Reed 2006-09-01 15:03:15 EDT
Description of problem:
I am unable to view/edit a large number of files over an autofs-mounted NFS
directory.

Version-Release number of selected component (if applicable):

Here's all of the possibly-relevant stuff:
  autofs-5.0.1-0.rc2.1
  kernel-2.6.17-1.2608.fc6
  nfs-utils-lib-1.0.8-7.2
  nfs-utils-1.0.9-5.fc6
  portmap-4.0-65.2.2.1

How reproducible: every time

Steps to Reproduce:
1. boot
2. cd to a directory that is NFS-mounted
3. cat CVS/Root
  
Actual results:
$ cat CVS/Root
cat: CVS/Root: Input/output error

Expected results:
the contents of the file  ;)

Additional info:
dmesg has a large stack trace from the kernel; attaching as "dmesg.out.gz"
Comment 1 Benjamin Reed 2006-09-01 15:03:15 EDT
Created attachment 135406 [details]
output of dmesg
Comment 2 Benjamin Reed 2006-09-01 15:23:47 EDT
I just confirmed that reverting to kernel-2.6.17-1.2157_FC5 fixes it, so it must
be a kernel issue specifically (although going by the dmesg output, that was
pretty clearly the case anyways :)
Comment 3 Bill Nottingham 2006-09-01 16:37:53 EDT

*** This bug has been marked as a duplicate of 204859 ***

Note You need to log in before you can comment on or make changes to this bug.