Bug 205020 - xfs_repairs fails to recover filesystem (phase 6)
xfs_repairs fails to recover filesystem (phase 6)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
6
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Russell Cattelan
:
: 206869 (view as bug list)
Depends On: 205906
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-02 10:56 EDT by Mykola Ulianytskyi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 16:45:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mykola Ulianytskyi 2006-09-02 10:56:58 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
xfs_repair /dev/hda1

Steps to Reproduce:
1. xfs_repair /dev/hda1

Actual results:


Expected results:
Phase 6 - check inode connectivity...
        - resetting contents of realtime bitmap and summary inodes
        - ensuring existence of lost+found directory
        - traversing filesystem starting at / ...
rebuilding directory inode 128

fatal error -- can't read block 16777216 for directory inode 151153880

Additional info:
Fixed in xfsprogs 2.8.10
http://oss.sgi.com/bugzilla/show_bug.cgi?id=631

I already test in - it really resolve the problem!
Comment 1 Paul W. Frields 2006-09-20 20:58:18 EDT
*** Bug 206869 has been marked as a duplicate of this bug. ***
Comment 2 Valent Turkovic 2006-09-24 14:01:04 EDT
So when will we see updated packages in Fedora?
Comment 3 Russell Cattelan 2006-09-27 16:45:13 EDT
xfsprogs has been updated to 2.8.11

Note You need to log in before you can comment on or make changes to this bug.