Bug 206869 - xfsprogs prior to 2.8.10 have a really serious bug
xfsprogs prior to 2.8.10 have a really serious bug
Status: CLOSED DUPLICATE of bug 205020
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
: 206870 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-17 09:24 EDT by Valent Turkovic
Modified: 2013-07-02 22:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 20:58:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2006-09-17 09:24:56 EDT
Description of problem:
I know that you officially doesn't support anything but ext3 but you still put 
xfsprogs package with fedora and there is a really big problem with it.

xfsprogs prior to 2.8.10 have a really serious bug which leads to xfs partition 
errors and xfs_repair can't repair the errorous partition.

xfs partition crashes, gives read and write errors and running xfs_repair 
doesn't repair it. 

The bug is described in here:
http://oss.sgi.com/bugzilla/show_bug.cgi?id=631

You need to put an updated xfsprogs 2.8.10 or newer package for fedora core 5, 
and all other.

Thank you.

Version-Release number of selected component (if applicable):
xfs 2.6, fedora core 5

How reproducible:
just work with files on xfs partition, and soon they break

Steps to Reproduce:
1.
2.
3.
  
Actual results:
fatal error -- can't read block 16777216 for directory inode 23727780

Expected results:
xfs_repair should repair all errors on xfs partition

Additional info:
http://oss.sgi.com/bugzilla/show_bug.cgi?id=631
http://www.http://tinyurl.com/h4o9h
http://tinyurl.com/fhs29
Comment 1 Johan Kok 2006-09-17 09:30:13 EDT
*** Bug 206870 has been marked as a duplicate of this bug. ***
Comment 2 Valent Turkovic 2006-09-17 09:35:00 EDT
Steps to Reproduce:
1. unmount /home
2. xfs_repair /dev/hda6
3. and then I get this error: 
fatal error -- can't read block 16777216 for directory inode 23727780
Comment 3 Robert Scheck 2006-09-19 04:39:32 EDT
This bug report is a duplicate of bug 205020, please mark it as such, thanks.
Comment 4 Paul W. Frields 2006-09-20 20:58:06 EDT

*** This bug has been marked as a duplicate of 205020 ***

Note You need to log in before you can comment on or make changes to this bug.