Bug 20505 - Loopback installation crash
Loopback installation crash
Status: CLOSED DUPLICATE of bug 19928
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-07 22:01 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 14:50:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-07 22:01:41 EST
I have one 13Gb hard drive using FAT32 and I was trying to install Redhat 7.0-respin (whatever that means:) on a loopback filesystem.  The 
installation was a custom install with just a few of the default packages unselected.  I also saw this on another machine when using the plain 
workstation install.  When it crashed the program wrote a file called Anacdump.txt on a floppy disk.

------------------------------------------------------------------------------------------------------------------------------------------------
Machine Specs.
------------------------------------------------------------------------------------------------------------------------------------------------
Compaq Presario 5700T
PIII/450
128Mb RAM
13Gb HD
Voodoo3 3500
LG CD-RW CED-8042B

------------------------------------------------------------------------------------------------------------------------------------------------
Contents of Anacdump.txt
------------------------------------------------------------------------------------------------------------------------------------------------

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.GuiFstab instance at 84c2000>
mntPoint: /mnt/sysimage
selected: [ImageMagick, LPRng, MAKEDEV, Mesa, Mesa-devel, ORBit, ORBit-devel, SDL, SysVinit, XFree86, XFree86-75dpi-fonts, 
XFree86-devel, XFree86-libs, XFree86-tools, XFree86-twm, XFree86-xdm, XFree86-xfs, Xaw3d, Xaw3d-devel, Xconfigurator, anacron, apmd, 
arpwatch, ash, aspell, at, audiofile, audiofile-devel, aumix, authconfig, autoconf, automake, awesfx, basesystem, bash, bc, bdflush, bind-utils, 
binutils, bison, bug-buddy, byacc, bzip2, bzip2-devel, cdda2wav, cdecl, cdp, cdparanoia, cdrecord, chkconfig, chkfontpath, compat-libstdc++, 
console-tools, control-center, control-center-devel, control-panel, cpio, cpp, cproto, cracklib, cracklib-dicts, crontabs, ctags, cvs, cyrus-sasl, 
db1, db1-devel, db2, db3, desktop-backgrounds, dev, dev86, dhcpcd, dia, dialog, diffstat, diffutils, dip, docbook, dosfstools, dump, e2fsprogs, 
ed, ee, eject, elm, emacs, esound, esound-devel, exmh, expect, extace, fetchmail, file, filesystem, fileutils, findutils, finger, flex, fortune-mod, 
freetype, ftp, gawk, gcc, gcc-c++, gcc-g77, gcc-objc, gd, gd-devel, gdb, gdbm, gdbm-devel, gdk-pixbuf, gdk-pixbuf-devel, gdm, gedit, gettext, 
gftp, ghostscript, ghostscript-fonts, gimp, gimp-devel, glade, glib, glib-devel, glibc, glibc-devel, gmc, gmp, gnome-applets, gnome-audio, 
gnome-audio-extra, gnome-core, gnome-core-devel, gnome-libs, gnome-libs-devel, gnome-linuxconf, gnome-media, gnome-objc, 
gnome-objc-devel, gnome-pim, gnome-pim-devel, gnome-print, gnome-users-guide, gnome-utils, gnorpm, gnotepad+, gnumeric, gnupg, gphoto, 
gpm, gpm-devel, gqview, grep, groff, groff-perl, gtk+, gtk+-devel, gtk-engines, gtop, guile, gv, gzip, hdparm, ical, imlib, imlib-cfgeditor, 
imlib-devel, indent, indexhtml, inews, info, initscripts, ipchains, iproute, iptables, iputils, isapnptools, isdn-config, isdn4k-utils, jadetex, 
kbdconfig, kernel, kernel-headers, kernel-pcmcia-cs, kernel-utils, kernelcfg, krb5-devel, krb5-libs, kudzu, kudzu-devel, less, libghttp, 
libghttp-devel, libglade, libglade-devel, libgtop, libgtop-devel, libjpeg, libjpeg-devel, libpng, libpng-devel, librep, libstdc++, libstdc++-devel, 
libtermcap, libtermcap-devel, libtiff, libtiff-devel, libtool, libtool-libs, libungif, libungif-devel, libxml, libxml-devel, lilo, links, linuxconf, 
linuxconf-devel, logrotate, losetup, lrzsz, lsof, ltrace, lynx, m4, magicdev, mailcap, mailx, make, man, man-pages, mc, memprof, metamail, 
mikmod, mingetty, minicom, mkbootdisk, mkinitrd, mkisofs, mktemp, mkxauth, modemtool, modutils, mount, mouseconfig, mpage, mpg123, 
mtools, multimedia, mutt, ncftp, ncompress, ncurses, ncurses-devel, net-tools, netcfg, netpbm, netpbm-devel, netpbm-progs, 
netscape-common, netscape-navigator, newt, newt-devel, nfs-utils, njamd, nmh, ntsysv, openjade, openldap, openssh, openssh-askpass, 
openssh-askpass-gnome, openssh-clients, openssl, openssl-devel, pam, passwd, patch, pciutils, pciutils-devel, perl, pidentd, pine, playmidi, 
playmidi-X11, plugger, pmake, pnm2ppa, popt, portmap, ppp, printtool, procmail, procps, psgml, psmisc, pspell, pump, pwdb, pygnome, 
pygnome-libglade, pygtk, pygtk-libglade, python, python-devel, python-xmlrpc, pythonlib, qt, quota, raidtools, rcs, rdate, readline, 
readline-devel, 
redhat-logos, redhat-release, rep-gtk, rep-gtk-gnome, rep-gtk-libglade, rhn_register, rhn_register-gnome, rhs-printfilters, rmt, rootfiles, rp-pppoe, 
rp3, rpm, rpm-build, rpm-devel, rpm-python, rsh, rsync, rusers, rwho, rxvt, samba-client, samba-common, sane, sash, sawfish, screen, sed, 
sendmail, setserial, setup, setuptool, sgml-common, sgml-tools, sh-utils, shadow-utils, shapecfg, sharutils, slang, slang-devel, slocate, slrn, 
smpeg, sndconfig, sox, stat, statserial, strace, stunnel, stylesheets, switchdesk, switchdesk-gnome, sysklogd, talk, tar, tcl, tclx, 
tcp_wrappers, tcsh, telnet, termcap, tetex, tetex-afm, tetex-dvilj, tetex-dvips, tetex-fonts, tetex-latex, tetex-xdvi, texinfo, textutils, time, 
timeconfig, timetool, tin, tix, tk, tkinter, tksysv, tmpwatch, traceroute, trn, umb-scheme, unzip, up2date, up2date-gnome, urlview, urw-fonts, 
usermode, utempter, util-linux, vim-common, vim-minimal, vixie-cron, which, whois, words, wvdial, xcdroast, xchat, xinitrc, xisdnload, 
xloadimage, xmailbox, xmms, xpaint, xpdf, xrn, xsane, xscreensaver, xsri, xxgdb, yp-tools, ypbind, zip, zlib, zlib-devel]
self: <image.CdromInstallMethod instance at 83fa968>
p: netscape-navigator
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-11-09 16:23:18 EST
What steps are required to reproduce this problem?
Comment 2 Need Real Name 2000-11-09 17:07:31 EST
1.  Workstation install
2.  When you start with Disk Druid, mount the FAT32 partition as /

The installer creates the DOS file and either while its formatting the filesystem or when it starts to install packages the installer crashes.
Comment 3 Michael Fulbright 2000-11-14 14:50:26 EST
Thank you for the additional information.

This is a dupe of bug 19928.

*** This bug has been marked as a duplicate of 19928 ***

Note You need to log in before you can comment on or make changes to this bug.