Bug 19928 - Error in anaconda resulted in aborted install of Redhat 7
Error in anaconda resulted in aborted install of Redhat 7
Status: CLOSED DUPLICATE of bug 19040
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 20505 20942 21660 22004 22293 22419 24207 24509 24544 24802 25035 25043 25380 25569 26707 26991 27609 28090 28444 28785 29285 29490 32117 39193 57573 57838 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-27 13:05 EDT by John Hinge
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 15:22:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Hinge 2000-10-27 13:05:13 EDT
Enclosed is the textdump from the aborted install :

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20,
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.GuiFstab instance at 84060e0>
mntPoint: /mnt/sysimage
selected: [ImageMagick, LPRng, MAKEDEV, Mesa, Mesa-devel, ORBit, ORBit-devel,
SDL, SDL-devel, SDL_image, SDL_image-devel, SysVinit, XFree86,
XFree86-75dpi-fonts, XFree86-devel, XFree86-libs, XFree86-tools, XFree86-twm,
XFree86-xdm, XFree86-xfs, Xaw3d, Xaw3d-devel, Xconfigurator, anacron, apache,
apmd, arpwatch, ash, aspell, at, audiofile, audiofile-devel, aumix, authconfig,
autoconf, automake, awesfx, basesystem, bash, bc, bdflush, bind-utils, binutils,
bison, bug-buddy, byacc, bzip2, bzip2-devel, cdda2wav, cdecl, cdp, cdparanoia,
cdrecord, chkconfig, chkfontpath, cleanfeed, compat-libstdc++, console-tools,
control-center, control-center-devel, control-panel, cpio, cpp, cproto,
cracklib, cracklib-dicts, crontabs, ctags, cvs, cyrus-sasl, db1, db1-devel, db2,
db3, desktop-backgrounds, dev, dev86, dhcpcd, dia, dialog, diffstat, diffutils,
dip, docbook, dosfstools, dump, e2fsprogs, ed, ee, eject, elm, emacs, emacs-X11,
emacs-nox, enlightenment, esound, esound-devel, exmh, expect, extace, fbset,
fetchmail, fetchmailconf, file, filesystem, fileutils, findutils, finger,
finger-server, flex, fnlib, fortune-mod, freeciv, freetype, ftp, gawk, gcc,
gcc-c++, gcc-g77, gcc-objc, gd, gd-devel, gdb, gdbm, gdbm-devel, gdk-pixbuf,
gdk-pixbuf-devel, gdm, gedit, gettext, getty_ps, gftp, ghostscript,
ghostscript-fonts, gimp, gimp-data-extras, gimp-devel, gimp-perl, glade, glib,
glib-devel, glibc, glibc-devel, gmc, gmp, gnome-applets, gnome-audio,
gnome-audio-extra, gnome-core, gnome-core-devel, gnome-games, gnome-games-devel,
gnome-libs, gnome-libs-devel, gnome-linuxconf, gnome-media, gnome-objc,
gnome-objc-devel, gnome-pim, gnome-pim-devel, gnome-print, gnome-users-guide,
gnome-utils, gnorpm, gnotepad+, gnuchess, gnumeric, gnupg, gphoto, gpm,
gpm-devel, gqview, grep, groff, groff-perl, gtk+, gtk+-devel, gtk-engines, gtop,
guile, gv, gzip, hdparm, ical, imlib, imlib-cfgeditor, imlib-devel, indent,
indexhtml, inews, info, initscripts, inn, inn-devel, ipchains, iproute,
iptables, iputils, isapnptools, isdn-config, isdn4k-utils, jadetex, kbdconfig,
kernel, kernel-headers, kernel-pcmcia-cs, kernel-utils, kernelcfg, krb5-devel,
krb5-libs, kudzu, kudzu-devel, less, libghttp, libghttp-devel, libglade,
libglade-devel, libgtop, libgtop-devel, libjpeg, libjpeg-devel, libpng,
libpng-devel, librep, libstdc++, libstdc++-devel, libtermcap, libtermcap-devel,
libtiff, libtiff-devel, libtool, libtool-libs, libungif, libungif-devel, libxml,
libxml-devel, licq, lilo, links, linuxconf, linuxconf-devel, locale_config,
logrotate, losetup, lrzsz, lsof, ltrace, lynx, m4, macutils, magicdev, mailcap,
mailx, make, man, man-pages, mc, memprof, metamail, mikmod, mingetty, minicom,
mkbootdisk, mkinitrd, mkisofs, mktemp, mkxauth, mod_perl, mod_php, modemtool,
modutils, mount, mouseconfig, mpage, mpg123, mtools, multimedia, mutt, ncftp,
ncompress, ncurses, ncurses-devel, net-tools, netcfg, netpbm, netpbm-devel,
netpbm-progs, netscape-common, netscape-communicator, newt, newt-devel,
nfs-utils, njamd, nmh, ntp, ntsysv, openjade, openldap, openssh,
openssh-askpass, openssh-askpass-gnome, openssh-clients, openssl, openssl-devel,
pam, passwd, patch, pciutils, pciutils-devel, perl, php, pidentd, pine,
playmidi, playmidi-X11, plugger, pmake, pnm2ppa, popt, portmap, ppp, printtool,
procinfo, procmail, procps, psgml, psmisc, pspell, pump, pwdb, pygnome,
pygnome-libglade, pygtk, pygtk-libglade, python, python-devel, python-xmlrpc,
pythonlib, qt, quota, raidtools, rcs, rdate, readline, readline-devel,
redhat-logos, redhat-release, rep-gtk, rep-gtk-gnome, rep-gtk-libglade,
rhn_register, rhn_register-gnome, rhs-printfilters, rmt, rootfiles, rp-pppoe,
rp3, rpm, rpm-build, rpm-devel, rpm-python, rpmfind, rsh, rsync, rusers, rwho,
rxvt, samba-client, samba-common, sane, sash, sawfish, sawfish-themer, screen,
sed, sendmail, setserial, setup, setuptool, sgml-common, sgml-tools, sh-utils,
shadow-utils, shapecfg, sharutils, slang, slang-devel, slocate, slrn, slrn-pull,
smpeg, sndconfig, sox, stat, statserial, strace, stunnel, stylesheets,
switchdesk, switchdesk-gnome, sysklogd, sysstat, talk, tar, tcl, tclx,
tcp_wrappers, tcpdump, tcsh, telnet, telnet-server, termcap, tetex, tetex-afm,
tetex-dvilj, tetex-dvips, tetex-fonts, tetex-latex, tetex-xdvi, texinfo,
textutils, time, timeconfig, timetool, tin, tix, tk, tkinter, tksysv, tmpwatch,
traceroute, trn, trojka, umb-scheme, unarj, unzip, up2date, up2date-gnome,
urlview, urw-fonts, usermode, utempter, util-linux, vim-common, vim-minimal,
vixie-cron, wget, which, whois, words, wvdial, xbill, xboard, xboing, xcdroast,
xchat, xcpustate, xdaliclock, xemacs, xemacs-info, xgammon, xinetd, xinitrc,
xisdnload, xjewel, xloadimage, xmailbox, xmms, xmms-gnome, xmorph, xosview,
xpaint, xpat2, xpdf, xpilot, xpuzzles, xrn, xsane, xscreensaver, xsri, xsysinfo,
xtrojka, xxgdb, yp-tools, ypbind, zip, zlib, zlib-devel]
self: <image.CdromInstallMethod instance at 83fa850>
p: enlightenment
changeloop: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-30 16:52:20 EST
Please attach the steps necessary to reproduce this bug, plus informatino about
your system.
Comment 2 John Hinge 2000-11-02 08:30:47 EST
Here's the additional info
Machine :
IBM Aptiva 860 :
Intel Pentium III 866, Slot 1
IBM Via Apollo Pro Chipset based MB
30 Gb HD
TEAC CD-W54E, CD writer
Samsung SD608 DVD/CD rom
Creative Labs, Geforce 256 DDR OEM Gfx card
Realtek RTL8029 PCI NIC
3Com Etherlink 10/100 PCCI NIC
Creative Labs SB Live player 1024
17" IBM E74 Display

Steps leading to the failure on my machine :
I booted off the normal bootimage, and selected an installation into an existing FAT partition
This went ok..
I got to select wich modules I wanted, as seen in the former dump
And got to select GFX mode for X-windows

Then the time came for formatting and installing.
The formatting went fine (it should.. just creating that huge file :)
Instead of installing anything I got an error message
that asked if i wanted to save a dump of the state of anakonda,
wich i did, whereafter I opened the bug on bugzilla

If any other info is needed, feel free to contact me again
Comment 3 John Hinge 2000-11-06 08:42:08 EST
After using the anaconda update from www.redhat.com The bug is gone, i.e. I can Install Redhat 7
on a FAT partition
Bug is therefor resolved as far as I'm concerned.. Thankyou for you time, and sorry If
I've inconvenienced anyone.
Comment 4 Michael Fulbright 2000-11-14 14:50:22 EST
*** Bug 20505 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2000-11-17 12:11:19 EST
*** Bug 20942 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2000-12-14 11:45:54 EST
*** Bug 22293 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2000-12-21 14:23:37 EST
*** Bug 22561 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2000-12-27 12:15:27 EST
*** Bug 21660 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2001-01-17 13:05:38 EST
*** Bug 22419 has been marked as a duplicate of this bug. ***
Comment 10 Michael Fulbright 2001-01-17 13:25:01 EST
*** Bug 24207 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2001-01-19 16:28:50 EST
*** Bug 22004 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2001-01-24 10:44:20 EST
*** Bug 24544 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2001-01-24 11:42:06 EST
*** Bug 24509 has been marked as a duplicate of this bug. ***
Comment 14 Michael Fulbright 2001-01-24 15:19:48 EST
*** Bug 24802 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2001-01-26 12:41:44 EST
*** Bug 25035 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fulbright 2001-01-29 19:46:18 EST
*** Bug 25043 has been marked as a duplicate of this bug. ***
Comment 17 Michael Fulbright 2001-01-31 13:31:53 EST
*** Bug 25380 has been marked as a duplicate of this bug. ***
Comment 18 Michael Fulbright 2001-02-01 18:18:07 EST
*** Bug 25569 has been marked as a duplicate of this bug. ***
Comment 19 Michael Fulbright 2001-02-08 15:39:21 EST
*** Bug 26707 has been marked as a duplicate of this bug. ***
Comment 20 Michael Fulbright 2001-02-11 22:23:54 EST
*** Bug 26991 has been marked as a duplicate of this bug. ***
Comment 21 Michael Fulbright 2001-02-14 12:39:34 EST
*** Bug 27609 has been marked as a duplicate of this bug. ***
Comment 22 Michael Fulbright 2001-02-21 17:40:33 EST
*** Bug 28444 has been marked as a duplicate of this bug. ***
Comment 23 Michael Fulbright 2001-02-22 12:14:09 EST
*** Bug 28785 has been marked as a duplicate of this bug. ***
Comment 24 Michael Fulbright 2001-02-23 12:15:44 EST
*** Bug 28090 has been marked as a duplicate of this bug. ***
Comment 25 Michael Fulbright 2001-02-25 11:19:04 EST
*** Bug 29285 has been marked as a duplicate of this bug. ***
Comment 26 Michael Fulbright 2001-02-25 23:11:04 EST
*** Bug 29490 has been marked as a duplicate of this bug. ***
Comment 27 Michael Fulbright 2001-03-05 15:21:56 EST

*** This bug has been marked as a duplicate of 19040 ***
Comment 28 Michael Fulbright 2001-03-05 15:22:40 EST

*** This bug has been marked as a duplicate of 19040 ***
Comment 29 Michael Fulbright 2001-03-21 14:19:46 EST
*** Bug 32117 has been marked as a duplicate of this bug. ***
Comment 30 Brent Fox 2001-05-07 11:23:42 EDT
*** Bug 39193 has been marked as a duplicate of this bug. ***
Comment 31 Jeremy Katz 2002-01-02 16:25:21 EST
*** Bug 57573 has been marked as a duplicate of this bug. ***
Comment 32 Jeremy Katz 2002-01-02 17:24:20 EST
*** Bug 57838 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.