Bug 205102 - INFO: possible recursive locking detected (ps2dev->cmd_mutex)
INFO: possible recursive locking detected (ps2dev->cmd_mutex)
Status: CLOSED DUPLICATE of bug 200025
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-04 02:46 EDT by Mihai Harpau
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 00:52:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log showing near identical dmesg trace (32.48 KB, text/plain)
2006-09-18 09:59 EDT, David Timms
no flags Details

  None (edit)
Description Mihai Harpau 2006-09-04 02:46:04 EDT
a full trace on x86 with kernel 2.6.17-1.2611.fc6 looks like:

 kernel: =============================================
 kernel: [ INFO: possible recursive locking detected ]
 kernel: 2.6.17-1.2611.fc6 #1
 kernel: ---------------------------------------------
 kernel: kseriod/168 is trying to acquire lock:
 kernel:  (&ps2dev->cmd_mutex#2){--..}, at: [<c0612ef0>] mutex_lock+0x21/0x24
 kernel: 
 kernel: but task is already holding lock:
 kernel:  (&ps2dev->cmd_mutex#2){--..}, at: [<c0612ef0>] mutex_lock+0x21/0x24
 kernel: 
 kernel: other info that might help us debug this:
 kernel: 4 locks held by kseriod/168:
 kernel:  #0:  (serio_mutex){--..}, at: [<c0612ef0>] mutex_lock+0x21/0x24
 kernel:  #1:  (&serio->drv_mutex){--..}, at: [<c0612ef0>] mutex_lock+0x21/0x24
 kernel:  #2:  (psmouse_mutex){--..}, at: [<c0612ef0>] mutex_lock+0x21/0x24
 kernel:  #3:  (&ps2dev->cmd_mutex#2){--..}, at: [<c0612ef0>] mutex_lock+0x21/0x24
 kernel: 
 kernel: stack backtrace:
 kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x171
 kernel:  [<c0405802>] show_trace+0xd/0x10
 kernel:  [<c040591b>] dump_stack+0x19/0x1b
 kernel:  [<c043b941>] __lock_acquire+0x778/0x99c
 kernel:  [<c043c0d6>] lock_acquire+0x4b/0x6d
 kernel:  [<c0612d81>] __mutex_lock_slowpath+0xbc/0x20a
 kernel:  [<c0612ef0>] mutex_lock+0x21/0x24
 kernel:  [<c0596c7c>] ps2_command+0x7e/0x2cd
 kernel:  [<c059c179>] psmouse_sliced_command+0x1c/0x5a
 kernel:  [<c059f677>] synaptics_pt_write+0x1e/0x43
 kernel:  [<c0596b66>] ps2_sendbyte+0x3e/0xd6
 kernel:  [<c0596cf6>] ps2_command+0xf8/0x2cd
 kernel:  [<c059bdac>] psmouse_probe+0x1d/0x68
 kernel:  [<c059cd20>] psmouse_connect+0xfa/0x221
 kernel:  [<c0594599>] serio_connect_driver+0x1e/0x2e
 kernel:  [<c05945bf>] serio_driver_probe+0x16/0x18
 kernel:  [<c0554eb2>] driver_probe_device+0x45/0x92
 kernel:  [<c0554f07>] __device_attach+0x8/0xa
 kernel:  [<c0554847>] bus_for_each_drv+0x3a/0x65
 kernel:  [<c0554f62>] device_attach+0x59/0x6e
 kernel:  [<c0554585>] bus_attach_device+0x16/0x2b
 kernel:  [<c05539d7>] device_add+0x1f8/0x2e0
 kernel:  [<c059501b>] serio_thread+0xc6/0x283
 kernel:  [<c04364d5>] kthread+0xc3/0xf2
 kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
 kernel: DWARF2 unwinder stuck at kernel_thread_helper+0x5/0xb
 kernel: Leftover inexact backtrace:
 kernel:  [<c0405802>] show_trace+0xd/0x10
 kernel:  [<c040591b>] dump_stack+0x19/0x1b
 kernel:  [<c043b941>] __lock_acquire+0x778/0x99c
 kernel:  [<c043c0d6>] lock_acquire+0x4b/0x6d
 kernel:  [<c0612d81>] __mutex_lock_slowpath+0xbc/0x20a
 kernel:  [<c0612ef0>] mutex_lock+0x21/0x24
 kernel:  [<c0596c7c>] ps2_command+0x7e/0x2cd
 kernel:  [<c059c179>] psmouse_sliced_command+0x1c/0x5a
 kernel:  [<c059f677>] synaptics_pt_write+0x1e/0x43
 kernel:  [<c0596b66>] ps2_sendbyte+0x3e/0xd6
 kernel:  [<c0596cf6>] ps2_command+0xf8/0x2cd
 kernel:  [<c059bdac>] psmouse_probe+0x1d/0x68
 kernel:  [<c059cd20>] psmouse_connect+0xfa/0x221
 kernel:  [<c0594599>] serio_connect_driver+0x1e/0x2e
 kernel:  [<c05945bf>] serio_driver_probe+0x16/0x18
 kernel:  [<c0554eb2>] driver_probe_device+0x45/0x92
 kernel:  [<c0554f07>] __device_attach+0x8/0xa
 kernel:  [<c0554847>] bus_for_each_drv+0x3a/0x65
 kernel:  [<c0554f62>] device_attach+0x59/0x6e
 kernel:  [<c0554585>] bus_attach_device+0x16/0x2b
 kernel:  [<c05539d7>] device_add+0x1f8/0x2e0
 kernel:  [<c059501b>] serio_thread+0xc6/0x283
 kernel:  [<c04364d5>] kthread+0xc3/0xf2
 kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Comment 1 David Lawrence 2006-09-05 11:32:47 EDT
Reassigning to correct owner, kernel-maint.
Comment 2 Stefan Skotte 2006-09-07 17:22:13 EDT
I see the same error on 2.6.17-1.2630.fc6 #1 SMP aswell.

Comment 3 Stefan Skotte 2006-09-08 04:37:01 EDT
Seems to be related to synaptics touchpad driver. 

Synaptics Touchpad, mode: 1, fw: 6.2, id: 0x81a0b1, caps: 0xa04793/0x300000

IBM Trackpoint Firmware: 0x0e buttons 3/3



Comment 4 David Timms 2006-09-18 09:59:27 EDT
Created attachment 136544 [details]
dmesg log showing near identical dmesg trace

I am seeing near identical stack trace during boot; the HP Compaq nx6120
notebook PC seems to operate fine. kernel=2.6.17-1.2647.fc6
[fc6t2+devel>2006-09-13].
differences in the traces:
orig.2439.    .2647.
kseriod/127   kseriod/173
trace-once    trace repeats after "DWARF2 unwinder stuck at
kernel_thread_helper..."
---
duplicated by bug 205102
Comment 5 David Timms 2006-09-18 10:03:13 EDT
Comment on attachment 136544 [details]
dmesg log showing near identical dmesg trace

I am seeing near identical stack trace during boot; the HP Compaq nx6120
notebook PC seems to operate fine. kernel=2.6.17-1.2647.fc6
[fc6t2+devel>2006-09-13].
differences in the traces:
orig.2439.    .2647.
kseriod/127   kseriod/173
trace-once    trace repeats after "DWARF2 unwinder stuck at
kernel_thread_helper..."
---
seems to duplicate bug 200025
Comment 6 Warren Togami 2006-09-28 00:52:20 EDT

*** This bug has been marked as a duplicate of 200025 ***

Note You need to log in before you can comment on or make changes to this bug.