Bug 200025 - possible recursive locking detected (ps2dev->cmd_mutex)
possible recursive locking detected (ps2dev->cmd_mutex)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 197897 202308 205102 206817 206925 208649 (view as bug list)
Depends On:
Blocks: FCMETA_LOCKDEP 208293
  Show dependency treegraph
 
Reported: 2006-07-24 17:28 EDT by Tim Vismor
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 19:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Vismor 2006-07-24 17:28:20 EDT
Description of problem:

A "possible recursive locking detected" message is displayed during boot up. The
system appears to operate normally. The message has been displayed by all
rawhide kernels for the past couple of weeks.

Version-Release number of selected component:

[vismor@azalea ~]$ uname -a
Linux azalea 2.6.17-1.2439.fc6 #1 SMP Sun Jul 23 22:05:10 EDT 2006 i686 i686
i386 GNU/Linux

How reproducible:

Always


Steps to Reproduce:

Occurs during boot up.

  
Actual results:

A relevant extract from the system log follows.

Jul 24 11:00:15 azalea kernel: sd 0:0:0:0: Attached scsi disk sda
Jul 24 11:00:15 azalea kernel: Synaptics Touchpad, model: 1, fw: 5.9, id:
0x2c6ab1, caps: 0x884793/0x0
Jul 24 11:00:15 azalea kernel: serio: Synaptics pass-through port at
isa0060/serio1/input0
Jul 24 11:00:15 azalea kernel: input: SynPS/2 Synaptics TouchPad as
/class/input/input1
Jul 24 11:00:15 azalea kernel: 
Jul 24 11:00:15 azalea kernel: =============================================
Jul 24 11:00:15 azalea kernel: [ INFO: possible recursive locking detected ]
Jul 24 11:00:15 azalea kernel: ---------------------------------------------
Jul 24 11:00:15 azalea kernel: kseriod/127 is trying to acquire lock:
Jul 24 11:00:15 azalea kernel:  (&ps2dev->cmd_mutex#2){--..}, at: [<c0606cb9>]
mutex_lock+0x21/0x24
Jul 24 11:00:15 azalea kernel: 
Jul 24 11:00:15 azalea kernel: but task is already holding lock:
Jul 24 11:00:15 azalea kernel:  (&ps2dev->cmd_mutex#2){--..}, at: [<c0606cb9>]
mutex_lock+0x21/0x24
Jul 24 11:00:15 azalea kernel: 
Jul 24 11:00:15 azalea kernel: other info that might help us debug this:
Jul 24 11:00:15 azalea kernel: 4 locks held by kseriod/127:
Jul 24 11:00:15 azalea kernel:  #0:  (serio_mutex){--..}, at: [<c0606cb9>]
mutex_lock+0x21/0x24
Jul 24 11:00:15 azalea kernel:  #1:  (&serio->drv_mutex){--..}, at: [<c0606cb9>]
mutex_lock+0x21/0x24
Jul 24 11:00:15 azalea kernel:  #2:  (psmouse_mutex){--..}, at: [<c0606cb9>]
mutex_lock+0x21/0x24
Jul 24 11:00:15 azalea kernel:  #3:  (&ps2dev->cmd_mutex#2){--..}, at:
[<c0606cb9>] mutex_lock+0x21/0x24
Jul 24 11:00:15 azalea kernel: 
Jul 24 11:00:15 azalea kernel: stack backtrace:
Jul 24 11:00:15 azalea kernel:  [<c04051ea>] show_trace_log_lvl+0x54/0xfd
Jul 24 11:00:15 azalea kernel:  [<c04057a6>] show_trace+0xd/0x10
Jul 24 11:00:15 azalea kernel:  [<c04058bf>] dump_stack+0x19/0x1b
Jul 24 11:00:15 azalea kernel:  [<c043b7ae>] __lock_acquire+0x773/0x997
Jul 24 11:00:15 azalea kernel:  [<c043bf43>] lock_acquire+0x4b/0x6c
Jul 24 11:00:15 azalea kernel:  [<c0606b4a>] __mutex_lock_slowpath+0xbc/0x20a
Jul 24 11:00:15 azalea kernel:  [<c0606cb9>] mutex_lock+0x21/0x24
Jul 24 11:00:15 azalea kernel:  [<c058e773>] ps2_command+0x65/0x2b8
Jul 24 11:00:15 azalea kernel:  [<c0593c9d>] psmouse_sliced_command+0x1c/0x5a
Jul 24 11:00:15 azalea kernel:  [<c0597197>] synaptics_pt_write+0x1e/0x43
Jul 24 11:00:15 azalea kernel:  [<c058e676>] ps2_sendbyte+0x3e/0xd6
Jul 24 11:00:15 azalea kernel:  [<c058e7ef>] ps2_command+0xe1/0x2b8
Jul 24 11:00:15 azalea kernel:  [<c059389a>] psmouse_probe+0x1d/0x68
Jul 24 11:00:15 azalea kernel:  [<c059483e>] psmouse_connect+0xfa/0x221
Jul 24 11:00:15 azalea kernel:  [<c058c111>] serio_connect_driver+0x1e/0x2e
Jul 24 11:00:15 azalea kernel:  [<c058c137>] serio_driver_probe+0x16/0x18
Jul 24 11:00:15 azalea kernel:  [<c054ca22>] driver_probe_device+0x45/0x92
Jul 24 11:00:15 azalea kernel:  [<c054ca77>] __device_attach+0x8/0xa
Jul 24 11:00:15 azalea kernel:  [<c054c3b7>] bus_for_each_drv+0x3a/0x65
Jul 24 11:00:15 azalea kernel:  [<c054cad2>] device_attach+0x59/0x6e
Jul 24 11:00:15 azalea kernel:  [<c054c0f5>] bus_attach_device+0x16/0x2b
Jul 24 11:00:15 azalea kernel:  [<c054b547>] device_add+0x1f8/0x2e0
Jul 24 11:00:15 azalea kernel:  [<c058cb6a>] serio_thread+0xc6/0x23c
Jul 24 11:00:15 azalea kernel:  [<c0436389>] kthread+0xc3/0xf2
Jul 24 11:00:15 azalea kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Jul 24 11:00:15 azalea kernel: kjournald starting.  Commit interval 5 seconds
Jul 24 11:00:15 azalea kernel: EXT3-fs: mounted filesystem with ordered data mode.

Additional info:

The hardware is a Thinkpadn T43.
Comment 1 Kjartan Maraas 2006-08-01 07:00:04 EDT
I see something very similar here with the latest rawhide kernel on a HP Compaq
nc4010 laptop:

[kmaraas@rivendell gnome214]$ uname -a
Linux rivendell 2.6.17-1.2462.fc6 #1 SMP Thu Jul 27 11:27:42 EDT 2006 i686 i686
i386 GNU/Linux

input: AT Translated Set 2 keyboard as /class/input/input0
Synaptics Touchpad, model: 1, fw: 5.9, id: 0x1b6eb1, caps: 0xa84793/0x100000
serio: Synaptics pass-through port at isa0060/serio4/input0
input: SynPS/2 Synaptics TouchPad as /class/input/input1
PM: Adding info for serio:serio5

=============================================
[ INFO: possible recursive locking detected ]
---------------------------------------------
kseriod/139 is trying to acquire lock:
 (&ps2dev->cmd_mutex#2){--..}, at: [<c0607711>] mutex_lock+0x21/0x24

but task is already holding lock:
 (&ps2dev->cmd_mutex#2){--..}, at: [<c0607711>] mutex_lock+0x21/0x24

other info that might help us debug this:
4 locks held by kseriod/139:
 #0:  (serio_mutex){--..}, at: [<c0607711>] mutex_lock+0x21/0x24
 #1:  (&serio->drv_mutex){--..}, at: [<c0607711>] mutex_lock+0x21/0x24
 #2:  (psmouse_mutex){--..}, at: [<c0607711>] mutex_lock+0x21/0x24
 #3:  (&ps2dev->cmd_mutex#2){--..}, at: [<c0607711>] mutex_lock+0x21/0x24

stack backtrace:
 [<c04051ea>] show_trace_log_lvl+0x54/0xfd
 [<c04057a6>] show_trace+0xd/0x10
 [<c04058bf>] dump_stack+0x19/0x1b
 [<c043b842>] __lock_acquire+0x773/0x997
 [<c043bfd7>] lock_acquire+0x4b/0x6c
 [<c06075a2>] __mutex_lock_slowpath+0xbc/0x20a
 [<c0607711>] mutex_lock+0x21/0x24
 [<c058ea67>] ps2_command+0x65/0x2b8
 [<c0593f91>] psmouse_sliced_command+0x1c/0x5a
 [<c059748b>] synaptics_pt_write+0x1e/0x43
 [<c058e96a>] ps2_sendbyte+0x3e/0xd6
 [<c058eae3>] ps2_command+0xe1/0x2b8
 [<c0593b8e>] psmouse_probe+0x1d/0x68
 [<c0594b32>] psmouse_connect+0xfa/0x221
 [<c058c405>] serio_connect_driver+0x1e/0x2e
 [<c058c42b>] serio_driver_probe+0x16/0x18
 [<c054cd0e>] driver_probe_device+0x45/0x92
 [<c054cd63>] __device_attach+0x8/0xa
 [<c054c6a3>] bus_for_each_drv+0x3a/0x65
 [<c054cdbe>] device_attach+0x59/0x6e
 [<c054c3e1>] bus_attach_device+0x16/0x2b
 [<c054b833>] device_add+0x1f8/0x2e0
 [<c058ce5e>] serio_thread+0xc6/0x23c
 [<c043641d>] kthread+0xc3/0xf2
 [<c0402005>] kernel_thread_helper+0x5/0xb
kjournald starting.  Commit interval 5 seconds
Comment 2 Dave Jones 2006-08-10 20:24:28 EDT
*** Bug 201106 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2006-09-14 01:44:00 EDT
*** Bug 202308 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2006-09-17 00:20:30 EDT
*** Bug 206817 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2006-09-17 01:49:49 EDT
*** Bug 197897 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2006-09-28 00:52:45 EDT
*** Bug 205102 has been marked as a duplicate of this bug. ***
Comment 7 Warren Togami 2006-09-28 00:55:05 EDT
*** Bug 206925 has been marked as a duplicate of this bug. ***
Comment 8 Warren Togami 2006-09-28 01:07:08 EDT
I don't know if this is related, but has anyone else been experiencing very rare
complete system deadlocks?

It seems to happen to me sometimes once a week, sometimes a few times a day. 
Each time it deadlocked was while I was moving the mouse using my Thinkpad T41's
synaptics touchpad while the system had background load doing other tasks.

IBM Thinkpad T41
Radeon 7500
Comment 9 Benny Amorsen 2006-10-03 08:59:17 EDT
These happen reliably on every bootup on a HP nx8220 laptop, including when
booting the FC6 prerelease DVD. So far they have caused no problems.
Comment 10 Tim Vismor 2006-10-03 16:04:41 EDT
FYI. Just installed and booted to the new rawhide kernel, i.e.

kernel-2.6.18-1.2726.fc6

This recursive locking message has finally gone away.
Comment 11 Joshua Giles 2006-10-09 11:27:09 EDT
*** Bug 208649 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.