Bug 20515 - trouble getting past xconfiguration
trouble getting past xconfiguration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-08 09:19 EST by Lloyd Buckner
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 18:48:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lloyd Buckner 2000-11-08 09:19:24 EST
I have an pIII 650, 256ram, 30gig hd, sblive sound, prophet 3d 32mg geforce video, 40x cd-rom and 8x4x24 creative lab 8532e cdrw. I am having 
problems just after file insallation with x configuration, it picks up my monitor as a plug&play with a 30-70khz hor. and 50-120hz ver. but when it 
goes to probe video it come up with an error message kicks me out to the manual conf. of my video. I've tried all the settings and it will not 
accept any of them
Comment 1 Trond Eivind Glomsrxd 2000-11-08 10:02:15 EST
What error message?  I need to know the exact one...

Also, are you using graphical or text-based configuration?

And while I'm at it: Which geforce?
Comment 2 Lloyd Buckner 2000-11-08 20:03:53 EST
the video card is a hercules prophet II mx w/ 32mg and a nvidia new generation gpu, the geforce2 mx chipset with a 256bit processor, the install was from 
text even though I tried to do it in graphical mode and the error message was; at boot: fatal server error, (next line)no screens found. The error message 
at xconfiguration(i will use conf.., from now)       error , There is a problem with your x conf.., you may go back and modify your conf. or exit now. And 
when i went back and manually modified I recieved this message:  x error , There was an error executing the x server in a probe mode you should try to 
conf.., the video card manually.
Comment 3 Lloyd Buckner 2000-11-09 22:19:58 EST
Hi, I found this on the net I'm not sure what exactly that they are doing but this what is happening to me.  The site is www.linuxbrocker.com and under 
search I put geforce2 mx and it came up with about 432 results, please keep it as simple as you can for I am a novice at this but learning fast




From: Rex Abert <rabert@math.fsu.edu>
              Subject: Re: GeForce2 MX and RedHat 7
              Date: Thu, 12 Oct 2000 11:59:55 -0400




              root wrote:

              > Hi!
              >
              > I cant get my GeForce2 MX card to work with RedHat7 (XFree 4.0.1a).
              > I cant even use the graphical installation option! It says: no screens
              > found!
              > I've tried the NVIDIA drivers, but I get an error while creating the
              > module
              > from the rpm.
              >
              > Anybody knows any good solution to this?

              I had best results using the tar.gz file from Nvidia for the
              NVIDIA_kernel.  Make sure /usr/src/linux/ points to
              the source for the kernel you are currently running, then "make" the
              kernel driver.

              The rpms leave a lot to be desired, so avoid them.

              I'm running this same card with zero problems.

              Rex
Comment 4 Lloyd Buckner 2000-11-10 21:51:14 EST
  again I went to the web and found this would it apply and how exactly do I do this seeing that I'm just getting my feet wet
 > If you want your card to work, you'll need to :
              > >
              > > a) Install XFree86 v4.0.1
              > > b) Go to  http://www.nvidia.com/Products/Drivers.nsf/Linux.html and
              > > download the drivers from there and install them.
              > >
              > > Be warned - the process is non-trivial. Follow the instructions on the
              > > NVIDIA website. Be paticularly careful to ensure that your
              > > distribution has not left any bits of the Mesa libs (an OpenGL clone)
              > > on your system that you are unaware of. This will cause either poor
              > > performance and/or failure of X to start at all.
              > >
              > > In my experience, it is best to install both XFree86 4.0.1 and the
              > > NVIDIA drivers from .tar.gz files, even if you are running RedHat or
              > > another .rpm - base distro. I had some problems with the .rpms of the
              > > drivers - my system did not work properly until I re-installed tem
              > > using the tarballs.
              > >
              > > I hope I have not put you off - the final result is well worth it!
              > >
              > > Regards,
              > >
              > > Barry Wilkes.
Comment 5 Lloyd Buckner 2000-11-14 16:02:29 EST
I also picked this up from an inquiry off the net

    Sorry I didn't reply sooner, but I'll outline what I had to do to get
a
GeForce card to work.  I am using a Hercules/Guillemot 3D Prophet II
with 32 MB video RAM, but the procedure should work with any GeForce
or TNT based card.  As you download the needed packages, read all
the FAQs and online docs at the sites that you can.

0. Log in as root

1.  First of all, you need XFree version 4.0.1.  If your distribution
didn't include this
version, go to www.xfree86.org and download the binaries.  This is a
fairly large
download, and may take a while. If I remember correctly, this is a
self-extracting
script that will install everything for you, BUT DON'T INSTALL THEM YET.

2. Install Mesa 3.2  (or higher) if it isn't already.  Check your
installation CD or go to
www.mesa3d.org and download either of
    MesaLib-3.2.tar.bz2
    MesaLib-3.2.tar.gz
Unzip with either
    bzip2 -d MesaLib-3.2.tar.bz2
    gunzip MesaLib-3.2.tar.gz

Then
     tar xvf MesaLib-3.2.tar

In the directory that appears, read and follow  the installation
instructions, which are
easy.  Get the demos if you want.  They are useful if you plan on doing
any graphics
programming.

3.  Go to www.nvidia.com and download the drivers for the card if you
haven't
already.  The driver consists of two parts, a kernel module that needs to
be built
for your machine, and the OpenGL libraries with hardware support for the
card.
The url is

    www.nvidia.com/Products/Drivers.nsf/Linux.html

Get the latest versions (0.9-5 as I write this) of

NVIDIA_GLX-0.9-5.tar.gz or NVIDIA_GLX-0.9-5.i386.rpm
NVIDIA_kernel-0.9-5.tar.gz

I used the rpm for the GLX library, but AVOID the rpms for the kernel
driver.  Read the installation FAQ at the site, and download it if you
wish to print it.  It gives good instructions with the exceptions I will
soon point out.

4. Now that you have all the pieces assembled, start the installation.

    First, edit the file /etc/inittab with your favorite text editor. And
find the
following section:

     # Default runlevel. The runlevels used by RHS are:
     # 0 - halt (Do NOT set initdefault to this)
     # 1 - Single user mode
     # 2 - Multiuser, without NFS (The same as 3, if you do not have
networking)
     # 3 - Full multiuser mode
     # 4 - unused
     # 5 - X11
     # 6 - reboot (Do NOT set initdefault to this)

     id:5:initdefault:

Change the last line to read

     id:3:initdefault:

This will boot your computer to text-only or console mode, which is
runlevel 3.  These runlevels are for a
RedHat system, other distros use other runlevel assignments.  Check your
documentation to be sure.

Install the XFree binaries.

Install the Mesa headers and libraries.

Install the NVIDIA_GLX package with

    rpm -i  NVIDIA_GLX-0.9-5.i386.rpm

This will detect and rename the Mesa versions of the OpenGL libraries.
This is good.

Now, to build the kernel driver, make sure that the directory

    /usr/src/linux

contains the source code to the version of the kernel you are currently
running.
Unpack the NVIDIA_kernel tarball with

    tar zxvf NVIDIA_kernel-0.9-5.tar.gz

cd to the directory this creates and type 'make' and then 'install.sh'

Now you are ready to use the new driver.  To configure your new card
and distro of XFree type

xf86config

This will present you with a series of questions about your mouse,
monitor, and
keyboard.  Check your monitor documenation before you start.  When you get

to the part where you select your card, choose card number 311, the nvidia
cards.

When you are finished, manually edit the /etc/X11/XF86Config file, and
change
the driver from "nv" to "nvidia", as descibed in Nvidia's FAQ.

You are now ready to test.  Type startx, and hopefully you will have a
working
X server.  When everything is working OK, you can change the
default runlevel back to 5.

Rex





Comment 6 Trond Eivind Glomsrxd 2000-11-14 16:06:03 EST
Using the Nvidia drivers is not a solution recommended by Red Hat.
Comment 7 Lloyd Buckner 2000-11-14 16:08:45 EST
so what do you recommend?
Comment 8 Lloyd Buckner 2000-11-18 16:56:55 EST
I did as you emailed me but how do I copy then send the log? can I convert the xlog  to send in the windows manner? That is the only way I can get to 
you since I'm stuck with out graphical interface and I'm just learning the root commands or any commands at all !!
Comment 9 Lloyd Buckner 2000-12-04 18:48:49 EST
what is going on I haven't heard from you all for a whike?
Comment 10 Preston Brown 2001-01-29 14:21:18 EST
GeForce will be supported out of the box in the next version of Red Hat Linux. 
It is well supported by our RawHide tree as of now.

Note You need to log in before you can comment on or make changes to this bug.