This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 205347 - Kernel panic - Unable to boot system after installation [unable to mount root fs on unknown-block(0,0)] - rawhide
Kernel panic - Unable to boot system after installation [unable to mount root...
Status: CLOSED DUPLICATE of bug 206453
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Desktop
: 205348 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 04:10 EDT by Mayank Jain
Modified: 2015-01-04 17:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 17:57:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mayank Jain 2006-09-06 04:10:28 EDT
Description of problem:
Just after the installation (and reboot), the boot process fails with this 
message

VFS: cannot open rood device "sda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


Version-Release number of selected component (if applicable):
anaconda-11.1.0.89-1.x86_64.rpm   
kernel-2.6.17-1.2617.2.1.fc6.x86_64.rpm  
grub-0.97-11.x86_64.rpm 


How reproducible:
Everytime

Steps to Reproduce:
1. Install Rawhide (this *might* be the one which will fo for fc6t3 freeze)
2. Reboot as mentioned in the end of install process
3. Kernel Panic!
  
Actual results:
Kernel Panic

Expected results:
Correct bootup

Additional info:
I have an AMD athlon 64 bit processor (3500+), SATA disk & performed a network 
installation. I also changed the default name "Fedora Core" in the boot menu 
(during install) to "Rawhide".

Following was my disk structure
/dev/sda1 - / - 80000 M - EXT3
/dev/sda2 - swap - 512 M
/dev/sda3 - /data - ~=70000M - EXT3
Comment 1 A S Alam 2006-09-06 04:24:02 EDT
*** Bug 205348 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2006-09-14 02:07:23 EDT
please attach /etc/modprobe.conf and /etc/fstab
Comment 3 Mayank Jain 2006-09-14 02:53:15 EDT
Hi Dave,
How can I attach the /etc/modprobe.conf and /etc/fstab files when the OS is not
booting? :)
Moreover, i've installed fc6t3 now & its working.
Comment 4 Daniel Malmgren 2006-09-16 07:31:12 EDT
I get the exact same error as Jain after installing FC6test3 (from the dvd image
from torrent.fedoraproject.org) on my new laptop. This is on a Core2Duo (T5600)
and SATA disk.

kernel version is 2.6.17-1.2630.fc6

My disk looks like the one above:
/dev/sda1 59GB ext3
/dev/sda2 1GB linux-swap

/etc/modprobe.conf:
alias scsi_hostadapter ata_piix

/etc/fstab:
LABEL=/   /         ext3    defaults       1 1
devpts    /dev/pts  devpts  gid=5,mode=620 0 0
tmpfs     /dev/shm  tmpfs   defaults       0 0
proc      /proc     proc    defaults       0 0
sysfs     /sys      sysfs   defaults       0 0
/dev/sda2 swap      swap    defaults       0 0
Comment 5 Daniel Malmgren 2006-09-16 07:53:14 EDT
Just a bit of more information. My computer is a ZNote 6015, based on Intel
945-GM/ICH7-M chipset. When starting in rescue mode from the disc the hd works
just fine. The modules that are loaded in rescue mode are (at least the ones
that seems like they could be relevant to me...):

raid456           157057  0
raid1              58449  0
raid0              41153  0
ata_piix           48841  3
libata            146801  1  ata_piix
iscsi_tcp          59073  0
libiscsi           61649  1  iscsi_tcp
scsi_transport_iscsi 67289  2  iscsi_tcp,libiscsi
sr_mod             52837  0
sd_mod             56513  3
scsi_mod          195217  6 
libata,iscsi_tcp,libiscsi,scsi_transport_iscsi,sd_mod_sd_mod
Comment 6 Daniel Malmgren 2006-09-17 07:52:41 EDT
Ok. Upgrading to latest rawhide kernel (2.6.17-1.2647.fc6) fixed this for me...
Comment 7 Daniel Malmgren 2006-09-17 08:02:41 EDT
Sorry for the bombing here, but I just realized what was nagging me the whole
time (though I stupidly enough didn't realize what it was). My default grub.conf
after the installation had no initrd in it! No wonder the modules wasn't loaded
like they should.

Could this be the same issue as the reporter above was experiencing? That upon
installation the initrd is never added to grub.conf, but it is upon upgrading?

I upgraded my kernel using "-Uvh" (Yes I know. That's not the best way. But it
worked ;-).
Comment 8 Mayank Jain 2006-09-18 03:43:15 EDT
Hi Daniel,

I have no way of checking that now... as I have done a clean installation of
fc6t3 & its working as expected.

:)
Mayank
Comment 9 Anssi Johansson 2006-09-18 03:48:14 EDT
I just installed FC6t3 (64bit version) on my SATA disk and got the same results.

This excerpt from /root/install.log might be interesting (booted to rescue mode
to see this):

...
Installing mkinitrd - 5.1.15-1.i386
Installing kernel - 2.6.17-1.2630.fc6.x86_64
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: echo: write error: Broken pipe
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
/sbin/mkinitrd: line 282: /sbin/nash: No such file or directory
no temporary directory could be found.
mkinitrd failed
error: %post(kernel-2.6.17-1.2630.fc6.x86_64) scriptlet failed, exit status 1
...
...
Installing mkinitrd - 5.1.15-1.x86_64
...


(/mnt/sysimage)/sbin/nash is in its correct location at the moment, but it may
not have been there during installation. /sbin/nash is apparently provided by
mkinitrd. There is no mention of initrd in /boot/grub/grub.conf after installation.

I wonder if this is somehow related to using 64bit version of Fedora? Daniel
didn't mention which variant he used, but at least his laptop would be capable
of running x86_64. I'm also wondering why mkinitrd-x86_64 is installed only
after installing mkinitrd-i386 and the kernel, I'd guess the proper variant of
mkinitrd would need to be already installed before installing the kernel.
Comment 10 Daniel Malmgren 2006-09-19 14:08:17 EDT
(In reply to comment #9)
> I wonder if this is somehow related to using 64bit version of Fedora? Daniel
> didn't mention which variant he used, but at least his laptop would be capable
> of running x86_64.

Oh, sorry. Yes, I'm on x86_64. A Core2Duo actually.
Comment 11 Anssi Johansson 2006-09-22 18:31:37 EDT
Bug 206453 has much more information about this bug. I'd even suggest marking
this as a duplicate of that bug, although this bug was filed earlier..
Comment 12 Will Woods 2006-09-28 17:57:39 EDT

*** This bug has been marked as a duplicate of 206453 ***

Note You need to log in before you can comment on or make changes to this bug.