Bug 205477 - kernel error: IRQ handler type mismatch for IRQ 0 during sata initialization
kernel error: IRQ handler type mismatch for IRQ 0 during sata initialization
Status: CLOSED DUPLICATE of bug 205479
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 205478 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 13:00 EDT by Christian Nolte
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 20:25:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2006-09-06 13:00:10 EDT
Description of problem:
During bootup initialization of the sata-devices the kernel gives the following
message: "IRQ handler type mismatch for IRQ 0". Bluetooth-Devices are unusable
(the bootup hangs when the bluetooth service is enabled on startup), no sound
through alsa is available. Furthermore the kernel gives the following
BUG-message: "BUG: warning at kernel/lockdep.c:1816/trace_hardirqs_on() (Not
tainted)".

The full dmesg output and lspci -vvv is attached.

Version-Release number of selected component (if applicable):

I have tried the following kernels with the exact same result:
kernel-2.6.17-1.2611.fc6
kernel-2.6.17-1.2617.2.1.fc6

How reproducible:
On every system startup.

Steps to Reproduce:
1. Install the mentioned kernel versions on a FC5-system with all the
   latest updates
2. Reboot the system
  
Actual results:
IRQ assigning problems

Expected results:
It should just work

Additional info:
The mentioned kernel-versions are used on a FC5 system because these are the
only ones working on my system (see bug #207059).
Comment 1 Dave Jones 2006-09-11 20:24:32 EDT
*** Bug 205478 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2006-09-11 20:25:30 EDT

*** This bug has been marked as a duplicate of 205479 ***

Note You need to log in before you can comment on or make changes to this bug.