Bug 205520 - tg3: No interrupt was generated using MSI
tg3: No interrupt was generated using MSI
Status: CLOSED DUPLICATE of bug 227657
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Gospodarek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 16:29 EDT by Aleksandar Milivojevic
Modified: 2014-06-29 18:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 17:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Milivojevic 2006-09-06 16:29:07 EDT
Description of problem:
From time to time I'm getting error message from tg3 device driver (Broadcom
gigabit ethernet) on the console (and in the log files).  Also, from time to
time the network card simply stops working.

The error message is:

tg3: eth0: No interrupt was generated using MSI, switching to INTx mode. Please
report this failure to the PCI maintainer and include system chipset information.

The motherboard is SuperMicro H8DSP-8.  The specs seem to say it has ServerWorks
HT2000 and ServerWorks HT1000 chipsets (see
http://www.supermicro.com/Aplus/motherboard/Opteron/HT2000/H8DSP-8.cfm for more
details).

lspci reports:

# lspci
00:01.0 PCI bridge: Broadcom HT1000 PCI/PCI-X bridge
00:02.0 Host bridge: Broadcom HT1000 Legacy South Bridge
00:02.1 IDE interface: Broadcom HT1000 Legacy IDE controller
00:02.2 ISA bridge: Broadcom HT1000 LPC Bridge
00:03.0 USB Controller: Broadcom HT1000 USB Controller (rev 01)
00:03.1 USB Controller: Broadcom HT1000 USB Controller (rev 01)
00:03.2 USB Controller: Broadcom HT1000 USB Controller (rev 01)
00:05.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
00:08.0 PCI bridge: Broadcom HT2000 PCI-X bridge (rev a3)
00:09.0 PCI bridge: Broadcom HT2000 PCI-X bridge (rev a3)
00:0a.0 PCI bridge: Broadcom HT2000 PCI-Express bridge (rev a3)
00:0b.0 PCI bridge: Broadcom HT2000 PCI-Express bridge (rev a3)
00:0c.0 PCI bridge: Broadcom HT2000 PCI-Express bridge (rev a3)
00:0d.0 PCI bridge: Broadcom HT2000 PCI-Express bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
00:19.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:19.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:19.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:19.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:0d.0 PCI bridge: Broadcom HT1000 PCI/PCI-X bridge (rev b2)
01:0e.0 RAID bus controller: Broadcom BCM5785 (HT1000) SATA Native SATA Mode
02:06.0 RAID bus controller: Adaptec AAC-RAID (rev 02)
04:04.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5780 Gigabit
Ethernet (rev 03)
04:04.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5780 Gigabit
Ethernet (rev 03)

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-42.0.2.EL

How reproducible:
Allways

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Aleksandar Milivojevic 2006-09-06 16:30:39 EDT
Typing too fast.  It isn't "network card".  The Ethernet card is integrated on
the motherboard.
Comment 2 John W. Linville 2006-11-30 16:34:03 EST
There is a patch (jwltest-pci-msi-quirk.patch) that might help in the test 
kernels here:

   http://people.redhat.com/linville/kernels/rhel4/

Please give those kernels a try and post the results here...thanks!
Comment 3 Aleksandar Milivojevic 2006-12-01 10:03:10 EST
Well...  There's a small problem.  It's a production box, and I can't really
take it down for testing or to play with it.  There's probability I'll have
another similar box on my desk in near future.  When/if it arrives, I'll give
those patches a try.  However it might be couple of months before that happens.
Comment 5 Andy Gospodarek 2006-12-20 15:35:19 EST
A patch that should resolve this issue was recently committed to a RHEL4
development build.  If you get a chance, please use one of the test kernels
located here:

http://people.redhat.com/~jbaron/rhel4/

Comment 6 Aleksandar Milivojevic 2006-12-22 11:11:45 EST
Hi Andy,

I've managed to find one of those machines on the devel side, and tested the new
kernel (kernel-smp-2.6.9-42.35.EL).  The problem is not solved.  It still
reports "No interrupt was generated using MSI, switching to INTx mode. Please
report this failure to the PCI maintainerand include system chipset information"
on both ethernet interfaces (eth0 and eth1) as soon as the interface is brought
up on boot.

Comment 7 Andy Gospodarek 2007-01-11 20:52:24 EST
Aleksandar, Thanks for the update.  I will look into this further and try to get
back to you soon.
Comment 8 Andy Gospodarek 2007-03-26 17:15:57 EDT
This message does seem to indicate that MSI doesn't work well on your system --
its really not a tg3 issue.

I'm guessing if you boot with 'pci=nomsi' you won't see these messages.  I'll
continue to look at it and see if there is anything that can be done.
Comment 9 Andy Gospodarek 2007-03-26 17:25:22 EDT
Hmmm, looks like that option might not be available on rhel4....
Comment 10 Andy Gospodarek 2007-05-01 17:02:41 EDT
Test kernels for this issue will be available here:

http://people.redhat.com/agospoda/#rhel4

Please test them and report back the results.

These kernels contain a patch that should disable MSI on this part:

01:0d.0 PCI bridge: Broadcom HT1000 PCI/PCI-X bridge (rev b2)

If these do not work, please attach the output from `lspci -t` and `lspci -n`

Thanks!
Comment 11 Aleksandar Milivojevic 2007-05-01 18:03:09 EDT
Sorry.  I work at different place now, and don't have access to anything with Broadcom HT1000 PCI/PCI-X 
bridge (that I'm aware of) anymore.

I'll forward this needinfo request to my previous manager, in case he is still interested in fixing the issue.
Comment 12 Andy Gospodarek 2007-10-05 17:36:17 EDT
This is definitely a duplicate of bug 227657.

*** This bug has been marked as a duplicate of 227657 ***
Comment 13 Aleksandar Milivojevic 2007-10-06 10:12:44 EDT
Hmmm...  Technically, bug 227657 is duplicate of this bug.  This bug is about one year older than bug 
227657.  Unless you intend to make bug 227657 publicly accessible, reopen this bug and mark it to 
depend on bug 227657.

Note You need to log in before you can comment on or make changes to this bug.