Bug 205534 - grep breaking on gzip files?
grep breaking on gzip files?
Status: CLOSED DUPLICATE of bug 202991
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: coreutils (Show other bugs)
4.4
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-06 18:06 EDT by Jed Reynolds
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-07 07:42:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jed Reynolds 2006-09-06 18:06:02 EDT
Description of problem:

grep errors with:
---
 *** glibc detected *** free(): invalid next size (normal): ***
Aborted.
---
when doing recursive grep in /var/log, other places.

Version-Release number of selected component (if applicable):
Linux 2.6.9-42.0.2.ELsmp 0x86_64,
Linux 2.6.9-34.0.2.ELsmp i686

How reproducible:

Consistently on i686 and x86_64 boxes Centos4.4. Recently upgraded from CentOS
4.3 to 4.4. 
I have large /var/log directories with plenty of gzipped logs.


Steps to Reproduce:
1. cd /var/log
2. grep -ri "Check Spelling & Mumble" *
3. (or) grep -ri "Check Spelling & Mumble" *gz
  
Actual results:
Fails with:
 *** glibc detected *** free(): invalid next size (normal): ***
Aborted.

Sometimes: 
 *** glibc detected *** realloc(): invalid next size: 0x000.... ***
Aborted.

Expected results:
No failure.

Additional info:

Grepping 7GB of compressed logs on one server, grepping 4GB logs on other
server. x86_64 Server had 35M or 3G+cache ram free; i686 server had 374M ram
free, 960M+cache.
Comment 1 Tim Waugh 2006-09-07 07:42:22 EDT
Looks like a duplicate of bug #202991.

*** This bug has been marked as a duplicate of 202991 ***

Note You need to log in before you can comment on or make changes to this bug.