Bug 202991 - Grep with certain expressions breaks in libc
Grep with certain expressions breaks in libc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.4
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://rackspace.com
:
: 205534 206930 211449 237683 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 13:57 EDT by Mike Jennings
Modified: 2010-10-22 01:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2007-0210
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 19:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file to grep through (36.53 KB, image/jpeg)
2006-08-17 13:57 EDT, Mike Jennings
no flags Details
test.c (661 bytes, text/plain)
2006-09-05 12:57 EDT, Tim Waugh
no flags Details
input (153 bytes, application/octet-stream)
2006-09-05 12:58 EDT, Tim Waugh
no flags Details

  None (edit)
Description Mike Jennings 2006-08-17 13:57:41 EDT
Description of problem:
grepping for a certain term in case insensitivity mode causes a glibc error




How reproducible:

[mike@michaeljennings ~]$ grep -i "insert into" 1-walkway.jpg 
*** glibc detected *** free(): invalid next size (fast): 0x08df7898 ***
Aborted

however exporting my lang to EN_US it works

[mike@michaeljennings ~]$ export LANG="en_US"
[mike@michaeljennings ~]$ grep -i "insert into" 1-walkway.jpg
Comment 1 Mike Jennings 2006-08-17 13:57:42 EDT
Created attachment 134400 [details]
file to grep through
Comment 2 Tom Weeks 2006-08-17 16:17:29 EDT
Can anyone test this on a EL4-U4 vs non U4 system?

Tweeks
Comment 7 Daniel Riek 2006-08-29 10:31:54 EDT
The component of this request is planned to be updated in Red Hat enterprise
Linux 4.5.

This enhancement request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux maintenance release.

Product Management has requested further review of this request by Red Hat
Engineering, for potential inclusion in a Red Hat Enterprise Linux Update
release for currently deployed products.

This request is not yet committed for inclusion in an Update release. 
Comment 8 Tim Waugh 2006-09-05 12:57:50 EDT
Created attachment 135589 [details]
test.c

Here's a glibc test case.  Input file to follow.
Comment 9 Tim Waugh 2006-09-05 12:58:36 EDT
Created attachment 135590 [details]
input

Input file.
Comment 10 Tim Waugh 2006-09-05 12:59:52 EDT
Changing component to glibc.
Comment 11 Jakub Jelinek 2006-09-05 15:47:58 EDT
Reproduced (on i386 only), debugging.
Comment 12 Tim Waugh 2006-09-07 07:42:34 EDT
*** Bug 205534 has been marked as a duplicate of this bug. ***
Comment 13 Tim Waugh 2006-09-18 06:23:05 EDT
*** Bug 206930 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Jelinek 2006-10-19 08:36:26 EDT
*** Bug 211449 has been marked as a duplicate of this bug. ***
Comment 22 James Olin Oden 2007-03-21 10:43:36 EDT
Would be possible to post the patch that fixed this problem.
Thanks...james
Comment 25 Jakub Jelinek 2007-04-26 11:49:59 EDT
*** Bug 237683 has been marked as a duplicate of this bug. ***
Comment 26 Red Hat Bugzilla 2007-05-01 19:03:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0210.html

Note You need to log in before you can comment on or make changes to this bug.