Bug 205575 - Upgrade to gstreamer 0.10.10
Upgrade to gstreamer 0.10.10
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 206381 (view as bug list)
Depends On:
Blocks: FC5Update 189617 199029
  Show dependency treegraph
 
Reported: 2006-09-07 08:56 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.10.10-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 09:15:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-09-07 08:56:49 EDT
The gstreamer (and associated plugins) versions are woefully out of date
(currently the FC-5 version of gstreamer is at 0.10.4) and recent version fix
bugs such as bug #189617 (titles for streaming radio stations).  Please upgrade
gstreamer and associated plugin packages.
Comment 1 Alex Lancaster 2006-09-23 20:33:57 EDT
gstreamer 0.10.10 is out.
Comment 2 Alex Lancaster 2006-10-07 03:15:26 EDT
Ping?  Any chance of an upgrade?
Comment 3 Brian Pepple 2006-11-02 16:56:40 EST
In general, packages don't get major upgrades during a release. If your wanting
the latest/greatest of a package you should probably be running Rawhide.
Comment 4 Alex Lancaster 2006-11-02 17:45:57 EST
(In reply to comment #3)
> In general, packages don't get major upgrades during a release. If your wanting
> the latest/greatest of a package you should probably be running Rawhide.

But it's not a major upgrade it's still in the gstreamer 0.10 series and is
binary compatible with all previous releases by design, and they make gstreamer
releases pretty often.  Since FC-6 is out, I'm now not so worried about FC-5,
but does this mean that FC-6 will be "stuck" with the same gstreamer that it
happened to have when it was released.  

Many new features and/or bugs fixed in gstreamer releases that are useful to
users that will be missed.  For example there are several bug reports on
rhythmbox Internet radio showing song titles that would have been fixed by an
upgrade, and also some major crashers.
Comment 5 Adam Jackson 2006-12-12 18:45:13 EST
*** Bug 206381 has been marked as a duplicate of this bug. ***
Comment 6 Christopher Brown 2007-01-02 10:16:30 EST
Jokosher is a complex gstreamer application (a non-linear audio editor) that has
garnered widespread attention in the FOSS community thanks to its constant
discussion on LUGRadio. Unfortunately the latest version depends on
gstreamer-plugins-good 0.10.5.  It would be great if we could get this updated
as I agree with the other bug filers that this is outdated and needs upgrading.
There is four months to go until FC7.
Comment 7 Bastien Nocera 2007-02-01 09:15:06 EST
$ rpm -q gstreamer
gstreamer-0.10.10-2.fc6

As for using Jokosher, if you want to using bleeding edge/not useful for many
people yet type of applications, you're better off installing your dependencies
by hand.

Note You need to log in before you can comment on or make changes to this bug.