Bug 205576 - after message delete next message is not selected
after message delete next message is not selected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 206168 206226 (view as bug list)
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-09-07 09:03 EDT by John Dennis
Modified: 2008-05-13 05:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-2.8.0-6.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 18:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 352982 None None None Never

  None (edit)
Description John Dennis 2006-09-07 09:03:40 EDT
version: evolution-2.8.0-1.fc6

If the currently selected message is deleted the selection is lost, it should
advance to the next message in the list. It does not matter how the message is
deleted (via the keyboard, toolbar button, etc.) the behavior is the same. I'm
not sure if it's relevant but the folder being viewed is IMAP with the view set
to hide deleted messages.

P.S.: this is very annoying behavior, it makes it difficult to process one's
inbox because everytime you delete a message you have to reselect the next message.
Comment 1 Matthew Barnes 2006-09-07 09:48:09 EDT
I've seen several complaints about this on the mailing lists, but for some
reason I can't reproduce this myself with evolution-2.8.0-1.fc6.

When I highlight a message and either press the Delete key, the Delete toolbar
button, or right-click and select Delete from the pop-up menu, the next message
in the list is highlighted and its contents displayed in the preview pane.

I tried this with the "Hide Deleted Messages" option both selected and unselected.

The only other package I can think of that might be relevant here is GTK+,
though that's a long shot.  I'm using gtk2-2.10.3-1.fc6.
Comment 2 John Dennis 2006-09-07 11:12:21 EDT
I'm also using gtk2-2.10.3-1.fc6

FWIW, the behavior is unique to a mail account. I have two mail accounts, one
for work and one personal. Both are IMAP and both have pretty much the same
configuration, although the IMAP server they connect may very well be a
different IMAP implementation. My work account exhibits the behavior, my
personal account does not. I've tried to see if there was a pattern, but so far
I'm at a loss. The only difference I see between the preferences for the
accounts is the work account is my default and uses SSL encryption, neither of
which seems a plausable condidtion to trigger the behavior. I could however
imagine a different response from the IMAP server could be a factor for why the
two accounts behave differently (what if an unexpected response caused a code
path to exit early?) just guessing ....

I seem to recall there is an environment variable one can turn on to produce
debugging information with evolution. What is it? Would that help diagnose the
problem?
Comment 3 John Dennis 2006-09-07 11:18:28 EDT
One thing you might try Matthew when trying to reproduce the problem is to see
if multiple mail accounts is a necessary condidtion.
Comment 4 John Dennis 2006-09-07 11:36:26 EDT
Ahh ... I think I see a necessary condition to trigger the behavior. In the
account which exhibits the behavior if you turn off "Hide Messages Marked for
Deletion", then after deletion the next message is selected. If you toggle the
"hide" back on it fails to select the next message. Behavior is very consistent
when toggling the hide flag.
Comment 5 Mike Chambers 2006-09-07 15:05:17 EDT
I am experiencing the same thing with the "hide deleted messages" option on and
off.  It doesn't highlight with the option on, and it does continue to highlight
with the option off.  This is using POP3, so it seems consistant no matter how
mail is retreived, or where it's stored.
Comment 6 John Dennis 2006-09-08 17:27:02 EDT
Almost by accident I discovered message threading seems to trigger the failure.
If threading is on the next message is not selected after deletion, if threading
is disabled you get the expected behavior.

I think this explains why I was seeing different behavior between mail accounts,
the working account did not have threading turned on, the failing account did.

toggle Ctrl-T and I expect you can toggle the problem.
Comment 7 Matthew Barnes 2006-09-12 15:31:55 EDT
*** Bug 206168 has been marked as a duplicate of this bug. ***
Comment 8 Matthias Clasen 2006-09-12 22:58:51 EDT
Nicolas,I appreciate that you consider this an important bug, but
please leave the tracker bug as a planning tool to us.
Comment 9 Matthew Barnes 2006-09-13 00:35:12 EDT
*** Bug 206226 has been marked as a duplicate of this bug. ***
Comment 10 Nicolas Mailhot 2006-09-13 04:27:11 EDT
(In reply to comment #8)
> Nicolas,I appreciate that you consider this an important bug, but
> please leave the tracker bug as a planning tool to us.

I'd be happy to use the tacker bug properly, but it's only described as "desktop
issues" now. Makes it hard for external testers like me to guess what rules to
follow there.
Comment 11 Matthias Clasen 2006-09-13 09:34:16 EDT
True. I have added a comment to the tracker bug now.
Comment 12 Matthew Barnes 2006-09-16 18:07:45 EDT
Looks like this is a side effect of a bug that Behdad reported upstream.
http://bugzilla.gnome.org/show_bug.cgi?id=352982
Comment 13 Matthew Barnes 2006-09-21 18:01:21 EDT
Fixed in evolution-2.8.0-6.fc6
Comment 14 Mike Chambers 2006-09-23 15:33:36 EDT
-5 is the only version I have seen in the last couple days.  Is -6 having build
problems in rawhide or something as still don't see it.
Comment 15 Matthew Barnes 2006-09-23 16:52:41 EDT
Since we're in feature freeze right now we have a more cumbersome process for
pushing updates out.  It looks like release 6 was overlooked, so I've
re-requested that it be pushed to Rawhide.  Sorry for the delay.
Comment 16 Nicole Dai 2006-10-12 23:05:44 EDT
Confirmed that it was fixed in evolution-2.8.0-6.fc6.

Note You need to log in before you can comment on or make changes to this bug.