Bug 20574 - Traceback (innermost last):
Traceback (innermost last):
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-09 08:24 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 21:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
help (966 bytes, text/plain)
2000-11-09 08:24 EST, Need Real Name
no flags Details
Traceback (innermost last): (1.21 KB, patch)
2001-03-31 12:00 EST, arie cohen
no flags Details | Diff

  None (edit)
Description Need Real Name 2000-11-09 08:24:20 EST
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 69, 
in systemMounted
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 30, 
in mountMedia
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
fstype: vfat
location: /tmp/hdimage
devName: /tmp/hda5
readOnly: 0
device: /tmp/hda5

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10

<failed>
Comment 1 Need Real Name 2000-11-09 08:24:56 EST
Created attachment 5181 [details]
help
Comment 2 yuyama 2001-03-04 13:16:03 EST
The bug problem is reproduced at my machine. (03/04/2001) 

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1664, in 
doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 895, in 
write
    config4 = self.Version4Config ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 1173, in 
Version4Config
    info["enableVariant"] = ""
NameError: info

Local variables in innermost frame:
data: {'screenModes': '\012\011Subsection "Display"\012        \011Depth       
16\012                Modes       "1280x1024" \012
\011EndSubsection\012', 'videoRam': '', 'pex5Mod': '\012
\011Load "pex5"', 'XkbModel': 'microsoft', 'monitorVert': '50 - 
160', 'mouseDevice': 'psaux', 'cardVendor': 'ATI 
Mach64', 'cardsOptions': '\011# no known 
options', 'XkbRules': 'xfree86', 'cardBoardName': 'ATI 
Mach64', 'ia64Mods': '', 'XkbLayout': 'jp', 'nonSparcMods': '\012
\011Load "fbdevhw"', 'defaultDepth': '', 'XkbOptions': '', 'cardID': 'ATI 
Mach64', 'emulate3': 'no', 'enableOptions': '#', 'monitorHoriz': '30 - 
95', 'enableVariant': '#', 'XkbVariant': 'nodeadkeys', 'mouseProto': 'PS/2', 'fi
les': '\012# The location of the RGB database.  Note, this is the name of 
the\012# file minus the extension (like ".txt" or ".db").  There is 
normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and later 
now use a font server independent of\012# the X server to render fonts.\012
\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    
FontPath   "unix/:7100"\012'}
self: <xf86config.XF86Config instance at 829c2b0>
maxdepth: 16
res: 1280x1024
test: 0
mouseProto: PS/2
emulate3: no
modes: ['1280x1024']
depth: 32
screens: 
	Subsection "Display"
        	Depth       16
                Modes       "1280x1024" 
	EndSubsection


ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 3 arie cohen 2001-03-31 12:00:40 EST
Created attachment 14344 [details]
Traceback (innermost last):
Comment 4 arie cohen 2001-03-31 12:02:49 EST
please help solve the problem
Comment 5 Richard Swacen 2001-04-02 21:54:43 EDT
I HOPE THIS IS DUE TO IMPROPER OR NON FORMAT OF ROOT PARTITION.  ANY HELP ON 
BELOW IS DEEPLY APPRECIATED:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 102816
fsystem: ext2
self: <fstab.GuiFstab instance at 8446f90>
msg: Invalid argument
doFormat: 0
errno: 22
device: hdb2
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Thanks, Richard Swacen rswacen1@rochester.rr.com
Comment 6 Brent Fox 2001-04-03 16:25:32 EDT

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.