Bug 205799 - Yelp should own the /usr/share/gnome/help directory
Yelp should own the /usr/share/gnome/help directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 228561 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-08 12:14 EDT by Brian Pepple
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.16.2-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 14:57:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file patch to own /usr/share/gnome/help (905 bytes, patch)
2006-09-16 19:45 EDT, Brian Pepple
no flags Details | Diff

  None (edit)
Description Brian Pepple 2006-09-08 12:14:43 EDT
Description of problem: Currently, just about every package with help in gnome
owns this directory, and it makes more sense for just yelp to own it.
Comment 1 Matthew Barnes 2006-09-16 18:01:04 EDT
Matthias, any thoughts about this one?
Comment 2 Brian Pepple 2006-09-16 19:45:34 EDT
Created attachment 136460 [details]
Spec file patch to own /usr/share/gnome/help
Comment 3 Matthias Clasen 2006-09-16 21:15:33 EDT
Matt, in principle this is fine to do. I didn't touch this bug to prevent the
flood of "foo needs to require yelp" bugs that will inevitably follow once you
close this one...
Comment 4 Brian Pepple 2006-09-16 21:25:39 EDT
(In reply to comment #3)
> Matt, in principle this is fine to do. I didn't touch this bug to prevent the
> flood of "foo needs to require yelp" bugs that will inevitably follow once you
> close this one...

That shouldn't be a problem, since any package that has help should have the
scriptlets for scrollkeeper, that will automatically cause yelp to be a dependency.

http://fedoraproject.org/wiki/Packaging/ScriptletSnippets?action=show&redirect=ScriptletSnippets#head-a4ea5e1946bc113d19d24b4f5bfb543c579e5fc8

Comment 5 Matthew Barnes 2006-09-16 21:33:16 EDT
This sounds like a good post-FC6 exercise.
Comment 6 Bill Nottingham 2007-02-13 14:54:06 EST
*** Bug 228561 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2007-02-13 14:57:12 EST
Fixed in 2.16.2-3.fc7. Brian - not sure what you mean in comment #4, as I don't
see how scrollkeeper will bring in yelp.

Note You need to log in before you can comment on or make changes to this bug.