Bug 205895 - Error when trying to open any RPM or when trying to run system-install-packages
Summary: Error when trying to open any RPM or when trying to run system-install-packages
Status: CLOSED DUPLICATE of bug 205890
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages   
(Show other bugs)
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-09 18:01 UTC by Arch Willingham
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 19:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arch Willingham 2006-09-09 18:01:09 UTC
Description of problem:

Any time I dbl click on an RPM file or try to run
"/usr/sbin/system-install-packages", it gives me an exception occured error.

Version-Release number of selected component (if applicable):

I don't know how to find that info??


How reproducible:

Very

Steps to Reproduce:
1. Dbl click on any RPM file
2. or run "/usr/sbin/system-install-packages -?"
3.
  
Actual results:

I get an exception error

Expected results:

It shoudl run the RPM

Additional info:

This is the error:

[root@localhost ~]# /usr/sbin/system-install-packages /?
Loading "installonlyn" plugin
/?
Component: Software Installer
Summary: TB31e7d981 system-install-packages:109:populatePackages:AttributeError:
'SinglePackageInstaller' object has no attribute 'read_ts'

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 244, in ?
    main()
  File "/usr/sbin/system-install-packages", line 240, in main
    pkginst.run()
  File "/usr/sbin/system-install-packages", line 230, in run
    self.doRefresh()
  File "/usr/sbin/system-install-packages", line 90, in doRefresh
    self.populatePackages()
  File "/usr/sbin/system-install-packages", line 109, in populatePackages
    po = YumLocalPackage(ts=self.read_ts, filename=pkg)
AttributeError: 'SinglePackageInstaller' object has no attribute 'read_ts'

Local variables in innermost frame:
installs: []
self: <__main__.SinglePackageInstaller object at 0x8729ecc>
updates: []
pkg: /?

Comment 1 Jeremy Katz 2006-09-11 19:47:30 UTC

*** This bug has been marked as a duplicate of 205890 ***


Note You need to log in before you can comment on or make changes to this bug.