Bug 205915 - knodemgrd possible recursive locking detected
knodemgrd possible recursive locking detected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 207385 (view as bug list)
Depends On:
Blocks: FCMETA_LOCKDEP
  Show dependency treegraph
 
Reported: 2006-09-10 00:24 EDT by Anthony Green
Modified: 2015-01-04 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 19:23:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2006-09-10 00:24:51 EDT
Description of problem:
I get the following message when I plug in a firewire audio device:

Sep  9 20:09:14 berkeley kernel: ieee1394: Error parsing configrom for node
0-00:1023
Sep  9 20:09:14 berkeley kernel:
Sep  9 20:09:14 berkeley kernel: =============================================
Sep  9 20:09:14 berkeley kernel: [ INFO: possible recursive locking detected ]
Sep  9 20:09:14 berkeley kernel: 2.6.17-1.2630.fc6 #1
Sep  9 20:09:14 berkeley kernel: ---------------------------------------------
Sep  9 20:09:14 berkeley kernel: knodemgrd_0/764 is trying to acquire lock:
Sep  9 20:09:14 berkeley kernel:  (&s->rwsem){..--}, at: [<e0a214f9>]
nodemgr_probe_ne+0x231/0x370 [ieee1394]
Sep  9 20:09:14 berkeley kernel:
Sep  9 20:09:14 berkeley kernel: but task is already holding lock:
Sep  9 20:09:14 berkeley kernel:  (&s->rwsem){..--}, at: [<e0a21e9c>]
nodemgr_host_thread+0x734/0x8bd [ieee1394]
Sep  9 20:09:14 berkeley kernel:
Sep  9 20:09:14 berkeley kernel: other info that might help us debug this:
Sep  9 20:09:14 berkeley kernel: 1 lock held by knodemgrd_0/764:
Sep  9 20:09:14 berkeley kernel:  #0:  (&s->rwsem){..--}, at: [<e0a21e9c>]
nodemgr_host_thread+0x734/0x8bd [ieee1394]
Sep  9 20:09:14 berkeley kernel:
Sep  9 20:09:14 berkeley kernel: stack backtrace:
Sep  9 20:09:14 berkeley kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x171
Sep  9 20:09:14 berkeley kernel:  [<c0405802>] show_trace+0xd/0x10
Sep  9 20:09:14 berkeley kernel:  [<c040591b>] dump_stack+0x19/0x1b
Sep  9 20:09:14 berkeley kernel:  [<c043b915>] __lock_acquire+0x778/0x99c
Sep  9 20:09:14 berkeley kernel:  [<c043c0aa>] lock_acquire+0x4b/0x6d
Sep  9 20:09:14 berkeley kernel:  [<c04390bc>] down_read+0x2d/0x40
Sep  9 20:09:14 berkeley kernel:  [<e0a214f9>] nodemgr_probe_ne+0x231/0x370
[ieee1394]
Sep  9 20:09:14 berkeley kernel:  [<e0a21ebb>] nodemgr_host_thread+0x753/0x8bd
[ieee1394]
Sep  9 20:09:14 berkeley kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Sep  9 20:09:14 berkeley kernel: DWARF2 unwinder stuck at
kernel_thread_helper+0x5/0xb
Sep  9 20:09:14 berkeley kernel: Leftover inexact backtrace:
Sep  9 20:09:14 berkeley kernel:  [<c0405802>] show_trace+0xd/0x10
Sep  9 20:09:14 berkeley kernel:  [<c040591b>] dump_stack+0x19/0x1b
Sep  9 20:09:14 berkeley kernel:  [<c043b915>] __lock_acquire+0x778/0x99c
Sep  9 20:09:14 berkeley kernel:  [<c043c0aa>] lock_acquire+0x4b/0x6d
Sep  9 20:09:14 berkeley kernel:  [<c04390bc>] down_read+0x2d/0x40
Sep  9 20:09:14 berkeley kernel:  [<e0a214f9>] nodemgr_probe_ne+0x231/0x370
[ieee1394]
Sep  9 20:09:14 berkeley kernel:  [<e0a21ebb>] nodemgr_host_thread+0x753/0x8bd
[ieee1394]
Sep  9 20:09:14 berkeley kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Sep  9 20:09:16 berkeley kernel: doh, someone wants to mess with state set


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2630.fc6

How reproducible:

Steps to Reproduce:
1.Plug presonus firebox ieee1394 audio device in
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Linda Wang 2006-10-03 15:19:52 EDT
*** Bug 207385 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.