Bug 207385 - Possible recursive locking detected in kernel after unplugging FireWire soundcard
Possible recursive locking detected in kernel after unplugging FireWire sound...
Status: CLOSED DUPLICATE of bug 205915
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 17:33 EDT by Vedran Miletić
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 15:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vedran Miletić 2006-09-20 17:33:42 EDT
Description of problem:
=============================================
[ INFO: possible recursive locking detected ]
2.6.17-1.2630.fc6 #1
---------------------------------------------
knodemgrd_0/1111 is trying to acquire lock:
 (&s->rwsem){..--}, at: [<e0a7c4f9>] nodemgr_probe_ne+0x231/0x370 [ieee1394]

but task is already holding lock:
 (&s->rwsem){..--}, at: [<e0a7ce9c>] nodemgr_host_thread+0x734/0x8bd [ieee1394]

other info that might help us debug this:
1 lock held by knodemgrd_0/1111:
 #0:  (&s->rwsem){..--}, at: [<e0a7ce9c>] nodemgr_host_thread+0x734/0x8bd [ieee1394]

stack backtrace:
 [<c04051ee>] show_trace_log_lvl+0x58/0x171
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b915>] __lock_acquire+0x778/0x99c
 [<c043c0aa>] lock_acquire+0x4b/0x6d
 [<c04390bc>] down_read+0x2d/0x40
 [<e0a7c4f9>] nodemgr_probe_ne+0x231/0x370 [ieee1394]
 [<e0a7cebb>] nodemgr_host_thread+0x753/0x8bd [ieee1394]
 [<c0402005>] kernel_thread_helper+0x5/0xb
DWARF2 unwinder stuck at kernel_thread_helper+0x5/0xb
Leftover inexact backtrace:
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b915>] __lock_acquire+0x778/0x99c
 [<c043c0aa>] lock_acquire+0x4b/0x6d
 [<c04390bc>] down_read+0x2d/0x40
 [<e0a7c4f9>] nodemgr_probe_ne+0x231/0x370 [ieee1394]
 [<e0a7cebb>] nodemgr_host_thread+0x753/0x8bd [ieee1394]
 [<c0402005>] kernel_thread_helper+0x5/0xb
ieee1394: Node suspended: ID:BUS[0-01:1023]  GUID[000a9200d6013127]

Version-Release number of selected component (if applicable):
[vedran@coldharbour ~]$ uname -a
Linux coldharbour 2.6.17-1.2630.fc6 #1 SMP Wed Sep 6 16:16:03 EDT 2006 i686 i686
i386 GNU/Linux

It happens when I unplug my FireWire soundcard. Doesn't seem related to other
"recursive locking detected" bugs.
Comment 1 Linda Wang 2006-10-03 15:19:28 EDT
dup to Bug 205915 

*** This bug has been marked as a duplicate of 205915 ***

Note You need to log in before you can comment on or make changes to this bug.