Bug 20592 - /usr/bin/rexec fails to connect
/usr/bin/rexec fails to connect
Status: CLOSED DUPLICATE of bug 20441
Product: Red Hat Linux
Classification: Retired
Component: rsh (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-09 11:37 EST by Chris Taylor
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-09 11:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Taylor 2000-11-09 11:37:14 EST
/usr/bin/rexec (rsh-0.17-2.2) on an i686 box fails to connect to the
correct port - there seems to be a confusion over network and host
ordering of the port number.

Adding a call to ntohs on the port parameter of the rexec(3) call
fixes the problem.

(This was a fresh installation of 7.0-respin on an i686 box)
Comment 1 Pekka Savola 2000-11-20 17:18:01 EST

*** This bug has been marked as a duplicate of 20441 ***

Note You need to log in before you can comment on or make changes to this bug.