Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 20441 - RH7.0 rexec fails
RH7.0 rexec fails
Status: CLOSED DUPLICATE of bug 18886
Product: Red Hat Linux
Classification: Retired
Component: rsh (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
: 20592 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-06 17:18 EST by dnd
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 17:18:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dnd 2000-11-06 17:18:48 EST
Command executed on system "dndsd4" RH7.0 to remote system "dndsd3" RH6.2:

# rexec dndsd4 date

<Hostname>: Connection refused
rexec: Error in rexec system call
rexec: The following system error may itself be in error
rexec: Connection refused.

I tried the same command on a RH6.2 and it works just fine. I moved 
the /usr/bin/rexec executable to the RH7.0 system and that works fine on 
the RH6.2 system but fails on the RH7.0 system. I used strace to trace 
both situations:

1) rexec from RH7.0 to RH6.2 => Good trace

2) rexec from RH6.2 to RH7.0 => Bad trace


rexec command trace analysis
============================

strace shows initiation of a connection on a socket fails because of a bad 
destination socket number parameter for connect() function for rexec 
command.


From rexec good trace (rexec RH6.2 to RH7.0)
============================================

dndsd3                                   dndsd4
[RH6.2] <---- rexec dndsd3 date ------> [RH7.0]


I'm showing only two lines of trace produced from:
"strace -v rexec dndsd3 date"

... trace clipped...

socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 3
connect(3, {sin_family=AF_INET, sin_port=htons(512), sin_addr=inet_addr
("15.114.20.110")}}, 16) = 0
...

where input parameters for connect() function are: 

1) file descriptor to a socket = 3

2) socket address data structure for destination address =
 	{sin_family=AF_INET, sin_port=htons(512), sin_addr=inet_addr
("15.114.21.111")}}

3) address length = 16


From rexec bad trace (rexec RH7.0 to RH6.2)
===========================================

dndsd4                                   dndsd3
[RH7.0] <---- rexec dndsd3 date ------> [RH6.2]

I'm showing only two lines of trace produced from:
"strace -v rexec dndsd4 date"

.... trace clipped...

socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 3
connect(3, {sin_family=AF_INET, sin_port=htons(2), sin_addr=inet_addr
("15.114.21.112")}}, 16) = -1 ECONNREFUSED (Connection refused)
....

Return value for connect() shows: ECONNREFUSED (No one listening on remote 
address)

The above shows that the problem lies with NOT getting a good end-point 
with a good destination socket number on RH7.0.

Is this a problem with RH7.0 rexec or is it a problem with the network 
stack on RH7.0 since I've moved the RH7.0 /usr/bin/rexec executable onto a 
RH6.2 system and it works just fine in RH6.2 environment.
Comment 1 Pekka Savola 2000-11-20 17:17:58 EST
*** Bug 20592 has been marked as a duplicate of this bug. ***
Comment 2 Nalin Dahyabhai 2000-11-20 18:35:39 EST

*** This bug has been marked as a duplicate of 18886 ***

Note You need to log in before you can comment on or make changes to this bug.